summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mate.scm87
1 files changed, 45 insertions, 42 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index d0e73e5a47..ce62366985 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1490,48 +1490,51 @@ used to bring up authentication dialogs.")
(native-inputs (list desktop-file-utils))
(inputs
;; TODO: Add more packages
- (list at-spi2-core
- atril
- caja
- dbus
- dconf
- engrampa
- eom
- font-abattis-cantarell
- glib-networking
- gnome-keyring
- gvfs
- hicolor-icon-theme
- libmatekbd
- libmateweather
- libmatemixer
- marco
- mate-session-manager
- mate-settings-daemon
- mate-desktop
- mate-terminal
- mate-themes
- mate-icon-theme
- mate-power-manager
- mate-menus
- mate-panel
- mate-control-center
- mate-media
- mate-applets
- mate-user-guide
- mate-calc
- mate-backgrounds
- mate-netbook
- mate-utils
- mate-polkit
- mate-system-monitor
- mate-utils
- pluma
- pinentry-gnome3
- pulseaudio
- shared-mime-info
- yelp
- zenity))
+ (append (if (or (%current-target-system)
+ (supported-package? gnome-keyring))
+ (list gnome-keyring)
+ '())
+ (list at-spi2-core
+ atril
+ caja
+ dbus
+ dconf
+ engrampa
+ eom
+ font-abattis-cantarell
+ glib-networking
+ gvfs
+ hicolor-icon-theme
+ libmatekbd
+ libmateweather
+ libmatemixer
+ marco
+ mate-session-manager
+ mate-settings-daemon
+ mate-desktop
+ mate-terminal
+ mate-themes
+ mate-icon-theme
+ mate-power-manager
+ mate-menus
+ mate-panel
+ mate-control-center
+ mate-media
+ mate-applets
+ mate-user-guide
+ mate-calc
+ mate-backgrounds
+ mate-netbook
+ mate-utils
+ mate-polkit
+ mate-system-monitor
+ mate-utils
+ pluma
+ pinentry-gnome3
+ pulseaudio
+ shared-mime-info
+ yelp
+ zenity)))
(propagated-inputs
;; Default font that applications such as IceCat require.
(list font-dejavu))