summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/patches/r-fix-15899.patch17
-rw-r--r--gnu/packages/statistics.scm5
3 files changed, 2 insertions, 21 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 2adffd593c..6934c92681 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -579,7 +579,6 @@ dist_patch_DATA = \
gnu/packages/patches/qt4-tests.patch \
gnu/packages/patches/qt5-conflicting-typedefs.patch \
gnu/packages/patches/qt5-runpath.patch \
- gnu/packages/patches/r-fix-15899.patch \
gnu/packages/patches/ratpoison-shell.patch \
gnu/packages/patches/readline-link-ncurses.patch \
gnu/packages/patches/ripperx-libm.patch \
diff --git a/gnu/packages/patches/r-fix-15899.patch b/gnu/packages/patches/r-fix-15899.patch
deleted file mode 100644
index 40593d34e6..0000000000
--- a/gnu/packages/patches/r-fix-15899.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Without the "extern" keyword external applications linking against R (such as
-Shogun, for example) might not be linkable.
-
-See https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=15899 for details
-about this bug.
-
---- a/src/include/Rinterface.h (revision 66251)
-+++ b/src/include/Rinterface.h (working copy)
-@@ -84,7 +84,7 @@
- void fpu_setup(Rboolean);
-
- /* in unix/system.c */
--int R_running_as_main_program;
-+extern int R_running_as_main_program;
-
- #ifdef CSTACK_DEFNS
- /* duplicating Defn.h */
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0b9e081c69..91d988ebd4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -42,7 +42,7 @@
(define-public r
(package
(name "r")
- (version "3.2.0")
+ (version "3.2.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -50,8 +50,7 @@
version ".tar.gz"))
(sha256
(base32
- "0dagyqgvi8i3nw158qi2zpwm04s4ffzvnmk5niaksvxs30zrbbpm"))
- (patches (list (search-patch "r-fix-15899.patch")))))
+ "10n9yhs55v1nnmdgsrgfncw29vq3ly70n8gvy1f4lq7l0hzvr7fm"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags