summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am3
-rw-r--r--gnu/packages/algebra.scm5
-rw-r--r--gnu/packages/patches/arb-ldconfig.patch31
3 files changed, 36 insertions, 3 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 543a825923..74e65c7b5e 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -1,6 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-# Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
+# Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
# Copyright © 2013, 2014, 2015 Mark H Weaver <mhw@netris.org>
#
# This file is part of GNU Guix.
@@ -408,6 +408,7 @@ dist_patch_DATA = \
gnu/packages/patches/agg-am_c_prototype.patch \
gnu/packages/patches/alsa-lib-mips-atomic-fix.patch \
gnu/packages/patches/apr-skip-getservbyname-test.patch \
+ gnu/packages/patches/arb-ldconfig.patch \
gnu/packages/patches/asymptote-gsl2.patch \
gnu/packages/patches/ath9k-htc-firmware-binutils.patch \
gnu/packages/patches/ath9k-htc-firmware-gcc.patch \
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index dd6838140b..0f17403868 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -238,7 +238,7 @@ fast arithmetic.")
(define-public arb
(package
(name "arb")
- (version "2.7.0")
+ (version "2.8.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -247,7 +247,8 @@ fast arithmetic.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1rwkffs57v8mry63rq8l2dyw69zfs9rg5fpbfllqp3nkjnkp1fly"))))
+ "04hhcpshfkcq9fr4hixbhpps50yf9drk62xgkvlcaj5kb4nyrx7l"))
+ (patches (map search-patch '("arb-ldconfig.patch")))))
(build-system gnu-build-system)
(propagated-inputs
`(("flint" ,flint))) ; flint.h is included by arf.h
diff --git a/gnu/packages/patches/arb-ldconfig.patch b/gnu/packages/patches/arb-ldconfig.patch
new file mode 100644
index 0000000000..2102e716e3
--- /dev/null
+++ b/gnu/packages/patches/arb-ldconfig.patch
@@ -0,0 +1,31 @@
+Common subdirectories: arb-2.8.1.orig/acb and arb-2.8.1/acb
+Common subdirectories: arb-2.8.1.orig/acb_calc and arb-2.8.1/acb_calc
+Common subdirectories: arb-2.8.1.orig/acb_hypgeom and arb-2.8.1/acb_hypgeom
+Common subdirectories: arb-2.8.1.orig/acb_mat and arb-2.8.1/acb_mat
+Common subdirectories: arb-2.8.1.orig/acb_modular and arb-2.8.1/acb_modular
+Common subdirectories: arb-2.8.1.orig/acb_poly and arb-2.8.1/acb_poly
+Common subdirectories: arb-2.8.1.orig/arb and arb-2.8.1/arb
+Common subdirectories: arb-2.8.1.orig/arb_calc and arb-2.8.1/arb_calc
+Common subdirectories: arb-2.8.1.orig/arb_mat and arb-2.8.1/arb_mat
+Common subdirectories: arb-2.8.1.orig/arb_poly and arb-2.8.1/arb_poly
+Common subdirectories: arb-2.8.1.orig/arf and arb-2.8.1/arf
+Common subdirectories: arb-2.8.1.orig/bernoulli and arb-2.8.1/bernoulli
+Common subdirectories: arb-2.8.1.orig/doc and arb-2.8.1/doc
+Common subdirectories: arb-2.8.1.orig/examples and arb-2.8.1/examples
+Common subdirectories: arb-2.8.1.orig/fmpr and arb-2.8.1/fmpr
+Common subdirectories: arb-2.8.1.orig/fmprb and arb-2.8.1/fmprb
+Common subdirectories: arb-2.8.1.orig/fmpz_extras and arb-2.8.1/fmpz_extras
+Common subdirectories: arb-2.8.1.orig/hypgeom and arb-2.8.1/hypgeom
+Common subdirectories: arb-2.8.1.orig/mag and arb-2.8.1/mag
+diff -u arb-2.8.1.orig/Makefile.in arb-2.8.1/Makefile.in
+--- arb-2.8.1.orig/Makefile.in 2015-12-31 17:30:01.000000000 +0100
++++ arb-2.8.1/Makefile.in 2016-01-20 16:30:32.575298517 +0100
+@@ -101,6 +101,7 @@
+ $(LDCONFIG) -n "$(CURDIR)"; \
+ fi
+ ln -sf "$(ARB_LIB)" "$(ARB_LIBNAME)"; \
++ ln -sf "$(ARB_LIB)" "$(ARB_LIBNAME).$(ARB_MAJOR)"; \
+
+ libarb.a: $(OBJS) $(LIB_SOURCES) $(EXT_SOURCES) $(HEADERS) $(EXT_HEADERS) | build build/interfaces
+ $(AT)$(foreach ext, $(EXTENSIONS), $(foreach dir, $(patsubst $(ext)/%.h, %, $(wildcard $(ext)/*.h)), mkdir -p build/$(dir); BUILD_DIR=$(CURDIR)/build/$(dir); export BUILD_DIR; MOD_DIR=$(dir); export MOD_DIR; $(MAKE) -f $(CURDIR)/Makefile.subdirs -C $(ext)/$(dir) static || exit $$?;))
+Common subdirectories: arb-2.8.1.orig/partitions and arb-2.8.1/partitions