summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/music.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index dcda09a264..264fcd9d0f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -707,6 +707,8 @@ is subjective.")
(lambda* (#:key inputs #:allow-other-keys)
(chdir "TuxGuitar")
(substitute* "GNUmakefile"
+ (("GCJFLAGS\\+=(.*)" _ rest)
+ (string-append "GCJFLAGS=-fsource=1.4 -fPIC " rest))
(("PROPERTIES\\?=")
(string-append "PROPERTIES?= -Dswt.library.path="
(assoc-ref inputs "swt") "/lib"))