summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm4
-rw-r--r--gnu/packages/gcc.scm2
2 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 80a83aa73b..6dfe5c9cb7 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -871,10 +871,10 @@ and binaries, plus debugging symbols in the 'debug' output), and Binutils.")
("libc-debug" ,glibc-final "debug")))))
(define-public gcc-toolchain-4.8
- (gcc-toolchain gcc-final))
+ (gcc-toolchain gcc-4.8))
(define-public gcc-toolchain-4.9
- (gcc-toolchain gcc-4.9))
+ (gcc-toolchain gcc-final))
(define-public gcc-toolchain-5
(gcc-toolchain gcc-5))
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 73c6d488fb..1df5150ab3 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -354,6 +354,8 @@ Go. It also includes runtime support libraries for these languages.")
"1ny4smkp5bzs3cp8ss7pl6lk8yss0d9m4av1mvdp72r1x695akxq"))
(patches (list (search-patch "gcc-5.0-libvtv-runpath.patch")))))))
+;; Note: When changing the default gcc version, update
+;; the gcc-toolchain-* definitions accordingly.
(define-public gcc gcc-4.9)
(define-public (make-libstdc++ gcc)