summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3f3f16a9a4..590048e06c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -151,11 +151,15 @@ affine transformation (scale, rotation, shear, etc.)")
`(("cairo" ,cairo)
("graphite2" ,graphite2)
("icu4c" ,icu4c)))
+ (propagated-inputs
+ `(("glib" ,glib))) ; required by harfbuzz-gobject.pc
(native-inputs
- `(("pkg-config" ,pkg-config)
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
("python" ,python-2))) ; incompatible with Python 3 (print syntax)
(arguments
- `(#:configure-flags `("--with-graphite2=yes")))
+ `(#:configure-flags `("--with-graphite2"
+ "--with-gobject")))
(synopsis "OpenType text shaping engine")
(description
"HarfBuzz is an OpenType text shaping engine.")