summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 86e3f2bf00..512f1950a3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -336,7 +336,13 @@ $(prefix)/etc/init.d\n")))
(let ((bash (assoc-ref inputs "bash")))
(substitute* (string-append out "/bin/guix")
(("^#!.*/bash") (string-append "#! " bash "/bin/bash")))))
- #t))))))
+ #t)))
+
+ ;; The 'guix' executable has 'OUT/libexec/guix/guile' has
+ ;; its shebang; that should remain unchanged, thus remove
+ ;; the 'patch-shebangs' phase, which would otherwise
+ ;; change it to 'GUILE/bin/guile'.
+ (delete 'patch-shebangs))))
(native-inputs `(("pkg-config" ,pkg-config)
;; Guile libraries are needed here for