summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/julia-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 28c759a5c0..ac6584825b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1472,6 +1472,15 @@ valuable enough at this time.")
(("pip install")
(string-append (search-input-file inputs "bin/pip")
" install")))))
+ (add-after 'link-depot 'fix-test-git-submodule
+ ;; Git v2.38.1 fixes security issues and changes the default
+ ;; behaviour of `git submodule`. This substitution is a backport
+ ;; of the upstream patch, not yet released, fixing the test suite.
+ ;; https://github.com/JuliaDocs/Documenter.jl/commit/b5a5c65d02d136743e7c18ffebf8baba900484fc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "test/utilities.jl"
+ (("submodule add")
+ "-c protocol.file.allow=always submodule add"))))
(add-after 'link-depot 'remove-javascript-downloads
(lambda _
(substitute* "src/Writers/HTMLWriter.jl"