summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/texinfo.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 25498ae36e..7108d1e067 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -75,7 +75,8 @@
%standard-phases)
;; XXX: Work around <https://issues.guix.gnu.org/59616>.
- #:tests? ,(not (hurd-target?))))
+ #:tests? ,(and (not (hurd-target?))
+ (not (%current-target-system)))))
(inputs (list ncurses perl))
;; When cross-compiling, texinfo will build some of its own binaries with
;; the native compiler. This means ncurses is needed both in both inputs