summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm21
-rw-r--r--gnu/packages/web.scm21
2 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ee27fb9ab3..767a898c90 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -861,6 +861,27 @@ the caller.")
CPAN::Meta object are present.")
(license (package-license perl))))
+(define-public perl-cpanel-json-xs
+ (package
+ (name "perl-cpanel-json-xs")
+ (version "3.0114")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
+ "Cpanel-JSON-XS-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0jhi1v0631x4d14a7cpfnpjqhs34zkygxjn1nwvvr927awx5jx71"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-common-sense" ,perl-common-sense)))
+ (home-page "http://search.cpan.org/dist/Cpanel-JSON-XS")
+ (synopsis "JSON::XS for Cpanel")
+ (description "This module converts Perl data structures to JSON and vice
+versa.")
+ (license (package-license perl))))
+
(define-public perl-data-dump
(package
(name "perl-data-dump")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b3a049f7f6..8f1cf863d6 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -913,27 +913,6 @@ parameter parsing, file upload, cookie handling and header generation.")
inputs, in a manner reminiscent of how PHP does.")
(license l:bsd-2)))
-(define-public perl-cpanel-json-xs
- (package
- (name "perl-cpanel-json-xs")
- (version "3.0114")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/R/RU/RURBAN/"
- "Cpanel-JSON-XS-" version ".tar.gz"))
- (sha256
- (base32
- "0jhi1v0631x4d14a7cpfnpjqhs34zkygxjn1nwvvr927awx5jx71"))))
- (build-system perl-build-system)
- (propagated-inputs
- `(("perl-common-sense" ,perl-common-sense)))
- (home-page "http://search.cpan.org/dist/Cpanel-JSON-XS")
- (synopsis "JSON::XS for Cpanel")
- (description "This module converts Perl data structures to JSON and vice
-versa.")
- (license (package-license perl))))
-
(define-public perl-encode-locale
(package
(name "perl-encode-locale")