summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/cursynth.scm5
-rw-r--r--gnu/packages/patches/cursynth-wave-rand.patch12
3 files changed, 16 insertions, 2 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 3c057b36d8..9c91eac1d2 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -283,6 +283,7 @@ dist_patch_DATA = \
gnu/packages/patches/cssc-gets-undeclared.patch \
gnu/packages/patches/cssc-missing-include.patch \
gnu/packages/patches/curl-fix-test172.patch \
+ gnu/packages/patches/cursynth-wave-rand.patch \
gnu/packages/patches/dbus-localstatedir.patch \
gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/dmd-getpw.patch \
diff --git a/gnu/packages/cursynth.scm b/gnu/packages/cursynth.scm
index 54b3acc768..80f86da241 100644
--- a/gnu/packages/cursynth.scm
+++ b/gnu/packages/cursynth.scm
@@ -29,14 +29,15 @@
(define-public cursynth
(package
(name "cursynth")
- (version "1.4")
+ (version "1.5")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/cursynth/cursynth-"
version ".tar.gz"))
(sha256
- (base32 "1p9c54v9b0jjx33sammqsdi5xw65csly4cr1i08wv9x6r2yib55m"))))
+ (base32 "1dhphsya41rv8z6yqcv9l6fwbslsds4zh1y56zizi39nd996d40v"))
+ (patches (list (search-patch "cursynth-wave-rand.patch")))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
;; TODO: See https://github.com/iyoko/cursynth/issues/4 which currently
diff --git a/gnu/packages/patches/cursynth-wave-rand.patch b/gnu/packages/patches/cursynth-wave-rand.patch
new file mode 100644
index 0000000000..b01a6a0710
--- /dev/null
+++ b/gnu/packages/patches/cursynth-wave-rand.patch
@@ -0,0 +1,12 @@
+Related to https://github.com/mtytel/cursynth/issues/9
+
+--- a/mopo/src/wave.h 2014-06-25 14:10:57.827369578 -0500
++++ b/mopo/src/wave.h 2014-06-25 14:08:15.795376354 -0500
+@@ -19,6 +19,7 @@
+ #define WAVE_H
+
+ #include "mopo.h"
++#include <cstdlib>
+ #include <cmath>
+
+ #define LOOKUP_SIZE 2048