summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 270d665251..8d3b582841 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11814,10 +11814,15 @@ objects with some common interface. The most common examples are
@code{console_scripts} entry points, which define shell commands by
identifying a Python function to run. The @code{entrypoints} module contains
functions to find and load entry points.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-entrypoints))))))
(define-public python2-entrypoints
- (package-with-python2 python-entrypoints))
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-entrypoints)))
+ (propagated-inputs
+ (list python2-configparser))))
(define-public python-epc
(package