summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/mail.scm4
-rw-r--r--gnu/packages/patches/mutt-store-references.patch16
3 files changed, 20 insertions, 1 deletions
diff --git a/gnu-system.am b/gnu-system.am
index a3c56a800c..35e94b7dea 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -523,6 +523,7 @@ dist_patch_DATA = \
gnu/packages/patches/mumps-build-parallelism.patch \
gnu/packages/patches/mupdf-buildsystem-fix.patch \
gnu/packages/patches/mutt-CVE-2014-9116.patch \
+ gnu/packages/patches/mutt-store-references.patch \
gnu/packages/patches/net-tools-bitrot.patch \
gnu/packages/patches/ngircd-handle-zombies.patch \
gnu/packages/patches/ngircd-no-dns-in-tests.patch \
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 70b0b0298d..d14fdc7619 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -184,7 +184,9 @@ aliasing facilities to work just as they would on normal mail.")
(sha256
(base32
"0dzx4qk50pjfsb6cs5jahng96a52k12f7pm0sc78iqdrawg71w1s"))
- (patches (list (search-patch "mutt-CVE-2014-9116.patch")))))
+ (patches (map search-patch
+ '("mutt-CVE-2014-9116.patch"
+ "mutt-store-references.patch")))))
(build-system gnu-build-system)
(inputs
`(("cyrus-sasl" ,cyrus-sasl)
diff --git a/gnu/packages/patches/mutt-store-references.patch b/gnu/packages/patches/mutt-store-references.patch
new file mode 100644
index 0000000000..3b69c7b0bd
--- /dev/null
+++ b/gnu/packages/patches/mutt-store-references.patch
@@ -0,0 +1,16 @@
+By default 'mutt' embeds configure flags and the output of 'gcc -v',
+which contains the store file name of Bash and GCC. This patch makes
+sure we don't embed a reference to these in 'mutt'.
+
+--- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
++++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
+@@ -21,6 +21,8 @@ txt2c_fallback () {
+ echo ";"
+ }
+
++echo "unsigned char $1[] = \"value of '$1' not kept\";"
++exit 0
+ ./txt2c test </dev/null >/dev/null 2>&1 &&
+ ./txt2c "$1" ||
+ txt2c_fallback "$1"
+