summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm52
-rw-r--r--gnu/packages/django.scm4
-rw-r--r--gnu/packages/python-check.scm4
3 files changed, 11 insertions, 49 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 1182f10b09..571216c4d8 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1390,44 +1390,27 @@ same arguments.")
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")
- (version "2.1.0")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-xdist" version))
(sha256
(base32
- "0wh6pn66nncfs6ay0n863bgyriwsgppn8flx5l7551j1lbqkinc2"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Remove pre-compiled .pyc files from source.
- (for-each delete-file-recursively
- (find-files "." "__pycache__" #:directories? #t))
- (for-each delete-file (find-files "." "\\.pyc$"))
- #t))))
+ "1psf5dqxvc38qzxvc305mkg5xpdmdkbkkfiyqlmdnkgh7z5dx025"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f ; Lots of tests fail.
- #:phases
+ '(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-setup-py
- (lambda _
- ;; Relax pytest requirement.
- (substitute* "setup.py"
- (("pytest>=6\\.0\\.0") "pytest"))))
(replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (add-installed-pythonpath inputs outputs)
(invoke "pytest" "-vv"
"-n" (number->string (parallel-job-count)))))))))
- (native-inputs
- (list python-setuptools-scm))
- (propagated-inputs
- (list python-execnet python-pytest python-py python-pytest-forked))
- (home-page
- "https://github.com/pytest-dev/pytest-xdist")
+ (native-inputs (list python-setuptools-scm))
+ (propagated-inputs (list python-execnet python-pytest python-py
+ python-pytest-forked))
+ (home-page "https://github.com/pytest-dev/pytest-xdist")
(synopsis
"Plugin for py.test with distributed testing and loop-on-failing modes")
(description
@@ -1439,25 +1422,6 @@ program code to a remote location, executes there, and then syncs the
result back.")
(license license:expat)))
-(define-public python2-pytest-xdist
- (package-with-python2 python-pytest-xdist))
-
-(define-public python-pytest-xdist-next
- (package/inherit python-pytest-xdist
- (name "python-pytest-xdist")
- (version "2.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-xdist" version))
- (sha256
- (base32
- "19cy57jrf3pwi7x6fnbxryjvqagsl0yv736jnynvr3yqhlpxxv78"))))
- (propagated-inputs
- `(("python-execnet" ,python-execnet)
- ("python-pytest" ,python-pytest-6)
- ("python-pytest-forked" ,python-pytest-forked)))))
-
(define-public python-pytest-timeout
(package
(name "python-pytest-timeout")
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 1161d3bc18..238af51430 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -391,9 +391,7 @@ size and quality.")
" and not test_urls_cache_is_cleared")))
(format #t "test suite not run~%")))))))
(native-inputs
- (list python-django python-setuptools-scm
- ;; For tests.
- python-pytest-xdist-next))
+ (list python-django python-setuptools-scm python-pytest-xdist))
(propagated-inputs
(list python-pytest))
(home-page "https://pytest-django.readthedocs.org/")
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 5bbe544113..0e20d08e32 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -112,9 +112,9 @@ interfaces with pytest.")
(add-installed-pythonpath inputs outputs)
(invoke "pytest")))))))
(native-inputs
- (list python-pytest-flake8 python-pytest-xdist-next python-tabulate))
+ (list python-pytest-flake8 python-pytest-xdist python-tabulate))
(propagated-inputs
- (list python-pytest-6 python-six))
+ (list python-pytest python-six))
(home-page "https://github.com/nicoulaj/pytest-csv")
(synopsis "CSV reporter for Pytest")
(description "This package provides a plugin for Pytest that enables a