summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mpi.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 420291d7f0..abe4fac470 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
+;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,8 +55,12 @@
`(("libx11" ,libx11)
("cairo" ,cairo)
("ncurses" ,ncurses)
- ("numactl" ,numactl)
- ("expat" ,expat)))
+ ("expat" ,expat)
+ ,@(if (not (string-prefix? "armhf"
+ (or (%current-target-system)
+ (%current-system))))
+ `(("numactl" ,numactl))
+ '())))
(propagated-inputs
;; hwloc.pc lists it in 'Requires.private'.
`(("libpciaccess" ,libpciaccess)))