summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index b2f46959e6..445e94a67e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5388,3 +5389,32 @@ compiled.")
GLib/GObject code.")
(home-page "https://wiki.gnome.org/Projects/GFBGraph")
(license license:lgpl2.1+)))
+
+(define-public libgnomekbd
+ (package
+ (name "libgnomekbd")
+ (version "3.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "02bahnl3vaqyqyr99r9kwka84sxj8qdrz7x0bf97192dysqaa7n4"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
+ ("intltool" ,intltool)))
+ (propagated-inputs
+ ;; Referred to in .h files and .pc.
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("libxklavier" ,libxklavier)))
+ (home-page "https://www.gnome.org")
+ (synopsis "GNOME keyboard configuration library")
+ (description
+ "Libgnomekbd is a keyboard configuration library for the GNOME desktop
+environment, which can notably display keyboard layouts.")
+ (license license:lgpl2.0+)))