summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ftp.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/ftp.scm b/gnu/packages/ftp.scm
index e1e6191d03..a11265532a 100644
--- a/gnu/packages/ftp.scm
+++ b/gnu/packages/ftp.scm
@@ -139,18 +139,18 @@ FTP browser, as well as non-interactive commands such as 'ncftpput' and
(patches (search-patches "weex-vacopy.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (alist-replace 'configure
- ;; configure does not work followed by both "SHELL=..." and
- ;; "CONFIG_SHELL=..."; set environment variables instead
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bash (which "bash")))
- (setenv "SHELL" bash)
- (setenv "CONFIG_SHELL" bash)
- (zero? (system* bash "./configure"
- (string-append "--prefix=" out)))))
- %standard-phases)))
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ ;; configure does not work followed by both "SHELL=..." and
+ ;; "CONFIG_SHELL=..."; set environment variables instead
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bash (which "bash")))
+ (setenv "SHELL" bash)
+ (setenv "CONFIG_SHELL" bash)
+ (zero? (system* bash "./configure"
+ (string-append "--prefix=" out)))))))))
(home-page "http://weex.sourceforge.net/")
(synopsis "Non-interactive client for FTP synchronization")
(description