summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnupg.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 27db5c3d76..52a9fc5366 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -247,7 +247,13 @@ compatible to GNU Pth.")
(lambda _
(substitute* (find-files "tests" ".\\.scm$")
(("/usr/bin/env gpgscm")
- (string-append (getcwd) "/tests/gpgscm/gpgscm"))))))))
+ (string-append (getcwd) "/tests/gpgscm/gpgscm")))))
+ (add-before 'check 'set-home
+ ;; Some tests require write access to $HOME, otherwise leading to
+ ;; 'failed to create directory /homeless-shelter/.asy' error.
+ (lambda _
+ (setenv "HOME" "/tmp")
+ #t)))))
(home-page "https://gnupg.org/")
(synopsis "GNU Privacy Guard")
(description