summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/machine-learning.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 4bc37ad86d..cbc7509416 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -323,3 +323,22 @@ in terms of new algorithms.")
adaptive sparsity and the Wong algorithm for adaptively sparse gaussian
geometric models.")
(license license:lgpl3+)))
+
+(define-public r-nnet
+ (package
+ (name "r-nnet")
+ (version "7.3-12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nnet" version))
+ (sha256
+ (base32
+ "17amqnw9dpap2w8ivx53hxha2xrm0drwfnj32li0xk41hlz548r7"))))
+ (build-system r-build-system)
+ (home-page "http://www.stats.ox.ac.uk/pub/MASS4/")
+ (synopsis "Feed-forward neural networks and multinomial log-linear models")
+ (description
+ "This package provides functions for feed-forward neural networks with a
+single hidden layer, and for multinomial log-linear models.")
+ (license (list license:gpl2+ license:gpl3+))))