summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index ca6bae42c4..591f60307e 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -493,6 +493,13 @@ transactions from C or Python.")
(lambda _
(substitute* "setup.py"
(("'python-magic',") ""))))
+ ;; The test suite assumes we have pytest >= 2.9.0.
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=841146
+ (add-after 'unpack 'disable-failing-test
+ (lambda _
+ (substitute* "tests/comparators/utils.py"
+ (("skip\\(reason\\=\\\"requires \\{\\}\\\"\\.format\\(tool\\)\\)")
+ "skipif(True, reason=\"Requires pytest >= 2.9\")"))))
(add-before 'build 'disable-egg-zipping
(lambda _
;; Leave the .egg file uncompressed.