summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d1bdb6d66a..27b6fb3a62 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -554,7 +554,12 @@ providing the system administrator with some help in common tasks.")
(find-files "lib" "\\.a$")))
#t))))))
(inputs `(("zlib" ,zlib)
- ("ncurses" ,ncurses)))
+ ("ncurses" ,ncurses)
+
+ ;; XXX: This is so that the 'pre-check' phase can find it.
+ ,@(if (%current-target-system)
+ `(("net-base" ,net-base))
+ '())))
(native-inputs
`(("perl" ,perl)
("net-base" ,net-base))) ;for tests