summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/backup.scm4
-rw-r--r--gnu/packages/connman.scm6
-rw-r--r--gnu/packages/education.scm45
-rw-r--r--gnu/packages/engineering.scm26
-rw-r--r--gnu/packages/gnome.scm6
-rw-r--r--gnu/packages/guile.scm29
-rw-r--r--gnu/packages/linux.scm3
-rw-r--r--gnu/packages/networking.scm4
-rw-r--r--gnu/packages/openldap.scm21
-rw-r--r--gnu/packages/patches/ceph-disable-cpu-optimizations.patch10
-rw-r--r--gnu/packages/patches/fuse-overlapping-headers.patch28
-rw-r--r--gnu/packages/qt.scm7
-rw-r--r--gnu/packages/storage.scm5
-rw-r--r--gnu/packages/sync.scm10
-rw-r--r--gnu/packages/synergy.scm5
-rw-r--r--gnu/packages/xfce.scm32
-rw-r--r--gnu/packages/xml.scm23
18 files changed, 235 insertions, 30 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 7220c432a2..31239933ce 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -575,6 +575,7 @@ dist_patch_DATA = \
%D%/packages/patches/freeimage-CVE-2015-0852.patch \
%D%/packages/patches/freeimage-CVE-2016-5684.patch \
%D%/packages/patches/freeimage-fix-build-with-gcc-5.patch \
+ %D%/packages/patches/fuse-overlapping-headers.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-bug-71399.patch \
%D%/packages/patches/gcc-arm-link-spec-fix.patch \
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 74245e5812..f9c0a22a0d 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -55,7 +55,7 @@
(define-public duplicity
(package
(name "duplicity")
- (version "0.7.11")
+ (version "0.7.12")
(source
(origin
(method url-fetch)
@@ -65,7 +65,7 @@
version ".tar.gz"))
(sha256
(base32
- "01zcq9cwn4pvj68rihgjvcdgccnxvz4jrba38sbv6nqz19cs2ixh"))))
+ "1rhgrz2lm9vbfdp2raykrih1c6n2lw5jd572z4dsz488m52avjqi"))))
(build-system python-build-system)
(native-inputs
`(("util-linux" ,util-linux) ;setsid command, for the tests
diff --git a/gnu/packages/connman.scm b/gnu/packages/connman.scm
index 0fced0be79..5e00ffb4ee 100644
--- a/gnu/packages/connman.scm
+++ b/gnu/packages/connman.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017 Mathieu OTHACEHE <m.othacehe@gmail.com>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;;
;;; This file is part of GNU Guix.
@@ -135,7 +135,7 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
(define-public cmst
(package
(name "cmst")
- (version "2016.10.03")
+ (version "2017.03.18")
(source
(origin
(method url-fetch)
@@ -143,7 +143,7 @@ sharing) to clients via USB, ethernet, WiFi, cellular and Bluetooth.")
"https://github.com/andrew-bibb/cmst/releases/download/cmst-"
version "/cmst-" version ".tar.gz"))
(sha256
- (base32 "1xpn4sqnxzpsjjwh9hva9sn55xlryiz2f2mwpyj2l31janj7a082"))))
+ (base32 "16g9byxr1rkmrnzi6sjplpmkr8h6pqj7418jz30czqviw5qlkqwl"))))
(inputs
`(("qt" ,qt)))
(native-inputs
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 808be203c2..b600c2ee39 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages kde-frameworks) ; extra-cmake-modules
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -102,6 +104,49 @@ of categories with some of the activities available in that category.
")
(license license:gpl3+)))
+(define-public gcompris-qt
+ (package
+ (name "gcompris-qt")
+ (version "0.70")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://gcompris.net/download/qt/src/gcompris-qt-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "01r7i8dmwb2nlfyp0y0mzs8yydmvn5gq7xn1w7g21lysak1mliwa"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; Qml_box2d is unmaintained and not actually required for building
+ '(#:configure-flags (list "-DQML_BOX2D_MODULE=disabled")
+ #:tests? #f)) ; no test target
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("gettext" ,gettext-minimal)
+ ("perl" ,perl)))
+ (inputs
+ `(("python-2" ,python-2)
+ ("qt" ,qt))) ; Cannot find qtquick at runtime with modular qt.
+ (home-page "http://gcompris.net/index-en.html")
+ (synopsis "Educational games for small children")
+ (description
+ "Gcompris offers a large collection of educational games for small
+children, designed to be a unified interface to integrate more educational
+games. Language-oriented games contain vocabulary, sounds, and voices for
+many different languages.
+Currently available boards include:
+@enumerate
+@item learning how to use a mouse and keyboard
+@item learning simple arithmetic
+@item learning how to read an analog clock
+@item recognize letters after hearing their names
+@item reading practice
+@item small games (memory games, jigsaw puzzles, ...)
+@end enumerate\n")
+ (license license:gpl3+)))
+
(define-public tipp10
(package
(name "tipp10")
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index dd56af99da..20efe11a24 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -774,3 +774,29 @@ render model libraries.")
educational use. As such, there is an emphasis on capabilities that improve
the 'showing the effect of'-style of operation.")
(license license:gpl2+)))
+
+(define-public volk
+ (package
+ (name "volk")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://libvolk.org/releases/volk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bz3ywc6y5wmz3i8p4z2wbzhns8bc0ywdkl9qnxpcvfcscarbdlh"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("boost" ,boost)))
+ (native-inputs
+ `(("python-2", python-2)
+ ("python2-cheetah" ,python2-cheetah)))
+ (home-page "http://libvolk.org/")
+ (synopsis "Vector-Optimized Library of Kernels")
+ (description
+ "@code{volk} contains procedures with machine-specific optimizations
+for mathematical functions. It also provides an machine-independent
+interface to select the best such procedures to use on a given system.")
+ (license license:gpl3+)))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index fc19318b91..6c90b2379f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1897,10 +1897,10 @@ editors, IDEs, etc.")
(package
(inherit vte)
(name "vte-ng")
- (version "0.46.1.a")
+ (version "0.48.2.a")
(native-inputs
`(("gtk-doc" ,gtk-doc)
- ("gperf" ,gperf-3.0)
+ ("gperf" ,gperf)
("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
@@ -1912,7 +1912,7 @@ editors, IDEs, etc.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1c0czhsn28b5h4pk3kx89jjbdc5d2qkxhl4ywqvxfivphf2nicbp"))))
+ "0m0bqcppa9vzysxizbymwifpii1lgg1cjy7yphvb1ivxz1pk7bal"))))
(arguments
`(#:configure-flags '("CXXFLAGS=-Wformat=0")
#:phases (modify-phases %standard-phases
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9dd524e4b2..26606f9d36 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1768,4 +1768,33 @@ HTML (via SXML) or any other format for rendering.")
(home-page "http://dthompson.us/software/guile-syntax-highlight")
(license license:lgpl3+))))
+(define-public guile-sjson
+ (package
+ (name "guile-sjson")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dustycloud.org/misc/sjson-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "09hnh2brc7ihh8dv4g5hdmdj8rs8p9l3pmlgafkx145grdg7wprx"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'bootstrap
+ (lambda _ (zero? (system* "sh" "bootstrap.sh")))))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (home-page "https://gitlab.com/dustyweb/guile-sjson")
+ (synopsis "S-expression based json reader/writer for Guile")
+ (description "guile-sjson is a json reader/writer for Guile.
+It has a nice, simple s-expression based syntax.")
+ (license license:lgpl3+)))
+
;;; guile.scm ends here
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 42495a9e4f..0b299f9e55 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1459,7 +1459,8 @@ processes currently causing I/O.")
"/fuse-" version ".tar.gz"))
(sha256
(base32
- "0szi2vlsjxg03y4ji51jks34p269jqj5ify6l0ajsqq6f6y8pd0c"))))
+ "0szi2vlsjxg03y4ji51jks34p269jqj5ify6l0ajsqq6f6y8pd0c"))
+ (patches (search-patches "fuse-overlapping-headers.patch"))))
(build-system gnu-build-system)
(inputs `(("util-linux" ,util-linux)))
(arguments
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9fa7c8826c..3182443c19 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -305,14 +305,14 @@ receiving NDP messages.")
(define-public ethtool
(package
(name "ethtool")
- (version "4.8")
+ (version "4.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/network/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "0hsaxcka0ks76k23sb65c46i53hjm465sgxyn3m3301diqlgwga0"))))
+ "1fklbjwr41cvd5b7d1qvpl3bqzc4aak732r3m2wjhhgkxhk9f07h"))))
(build-system gnu-build-system)
(home-page "https://www.kernel.org/pub/software/network/ethtool/")
(synopsis "Display or change Ethernet device settings")
diff --git a/gnu/packages/openldap.scm b/gnu/packages/openldap.scm
index b67510647d..987719492f 100644
--- a/gnu/packages/openldap.scm
+++ b/gnu/packages/openldap.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages groff)
#:use-module (gnu packages icu4c)
+ #:use-module (gnu packages kerberos)
#:use-module (gnu packages linux)
#:use-module (gnu packages python)
#:use-module (gnu packages tls)
@@ -94,11 +95,27 @@
`(#:configure-flags
(list (string-append "--with-pam-seclib-dir="
(assoc-ref %outputs "out") "/lib/security/")
- (string-append "--with-ldap-conf-file="
- (assoc-ref %outputs "out") "/etc/nslcd.conf"))))
+ ;; nslcd cannot be convinced to look at run-time for its
+ ;; configuration file at a location that differs from the
+ ;; configured location.
+ "--with-ldap-conf-file=/etc/nslcd.conf")
+ #:phases
+ (modify-phases %standard-phases
+ ;; This is necessary because we tell nslcd with configure flags that
+ ;; it should look for its configuration file at /etc/nslcd.conf. The
+ ;; build system tries to install a default configuration to that very
+ ;; location.
+ (add-after 'unpack 'override-nslcd.conf-install-path
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile.in"
+ (("\\$\\(DESTDIR\\)\\$\\(NSLCD_CONF_PATH\\)")
+ (string-append (assoc-ref outputs "out")
+ "/etc/nslcd.conf.example")))
+ #t)))))
(inputs
`(("linux-pam" ,linux-pam)
("openldap" ,openldap)
+ ("mit-krb5" ,mit-krb5)
("python" ,python-2)))
(home-page "https://arthurdejong.org/nss-pam-ldapd")
(synopsis "NSS and PAM modules for LDAP")
diff --git a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
index 56a1654f29..f33eb629d6 100644
--- a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
+++ b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
@@ -15,16 +15,16 @@ don't add anything for i686.
#
# SIMD_COMPILE_FLAGS
#
-@@ -56,7 +51,7 @@
- if(HAVE_ARM_NEON)
+@@ -73,7 +68,7 @@
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
endif()
+
-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
+elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64|x86_64|AMD64")
set(HAVE_INTEL 1)
CHECK_C_COMPILER_FLAG(-msse HAVE_INTEL_SSE)
if(HAVE_INTEL_SSE)
-@@ -66,24 +61,4 @@
+@@ -83,26 +78,6 @@
if(HAVE_INTEL_SSE2)
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse2")
endif()
@@ -48,4 +48,6 @@ don't add anything for i686.
- if(HAVE_INTEL_SSE4_2)
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.2")
- endif()
- endif()
+ elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "(powerpc|ppc)64le")
+ set(HAVE_PPC64LE 1)
+ message(STATUS " we are ppc64le")
diff --git a/gnu/packages/patches/fuse-overlapping-headers.patch b/gnu/packages/patches/fuse-overlapping-headers.patch
new file mode 100644
index 0000000000..54f9c0e709
--- /dev/null
+++ b/gnu/packages/patches/fuse-overlapping-headers.patch
@@ -0,0 +1,28 @@
+This patch is from Debian, named '0006-arm64.patch'
+
+Author: Riku Voipio <riku.voipio@linaro.org>
+Description: fuse_kernel.h: clean includes
+ Use <linux/types.h> for linux and define types used for other operating systems
+ using <stdint.h> types (Closes: #752081).
+
+diff -Naurp fuse.orig/include/fuse_kernel.h fuse/include/fuse_kernel.h
+--- fuse.orig/include/fuse_kernel.h
++++ fuse/include/fuse_kernel.h
+@@ -88,12 +88,16 @@
+ #ifndef _LINUX_FUSE_H
+ #define _LINUX_FUSE_H
+
+-#include <sys/types.h>
++#ifdef __linux__
++#include <linux/types.h>
++#else
++#include <stdint.h>
+ #define __u64 uint64_t
+ #define __s64 int64_t
+ #define __u32 uint32_t
+ #define __s32 int32_t
+ #define __u16 uint16_t
++#endif
+
+ /*
+ * Version negotiation:
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index fb242a01da..074ef0b466 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1347,7 +1347,7 @@ contain over 620 classes.")
(define-public qtkeychain
(package
(name "qtkeychain")
- (version "0.7.0")
+ (version "0.8.0")
(source
(origin
(method url-fetch)
@@ -1355,7 +1355,7 @@ contain over 620 classes.")
"archive/v" version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0fka5q5cdzlf79igcjgbnb2smvwbwfasqawkzkbr34whispgm6lz"))))
+ (base32 "0bxi5pfhxdvwk8yxa06lk2d7lcibmfqhahbin82bqf3m341zd4ml"))))
(build-system cmake-build-system)
(native-inputs
`(("qttools" ,qttools)))
@@ -1370,7 +1370,8 @@ contain over 620 classes.")
(lambda _
(substitute* "CMakeLists.txt"
(("\\$\\{qt_translations_dir\\}")
- "${CMAKE_INSTALL_PREFIX}/share/qt/translations")))))))
+ "${CMAKE_INSTALL_PREFIX}/share/qt/translations"))
+ #t)))))
(home-page "https://github.com/frankosterfeld/qtkeychain")
(synopsis "Qt API to store passwords")
(description
diff --git a/gnu/packages/storage.scm b/gnu/packages/storage.scm
index 388eb10444..5d647bcd34 100644
--- a/gnu/packages/storage.scm
+++ b/gnu/packages/storage.scm
@@ -48,14 +48,14 @@
(define-public ceph
(package
(name "ceph")
- (version "12.0.1")
+ (version "12.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
version ".tar.gz"))
(sha256
(base32
- "1mgd7iqx9zgwims2bb8dbzhzv0p6z9vjxavbv8dampa34fzac3xc"))
+ "0l9v072ba28i984y5rwny9i11nmpyx5bl7awxg48plyadm2l3g14"))
(patches
(search-patches "ceph-skip-unittest_blockdev.patch"
"ceph-skip-collect-sys-info-test.patch"
@@ -223,6 +223,7 @@
(substitute* "src/test/osd/CMakeLists.txt"
(("^add_ceph_test\\(osd-bench\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-config\\.sh.*$") "\n")
+ (("add_ceph_test\\(osd-dup\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-markdown\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-reactivate\\.sh.*$") "\n")
(("^add_ceph_test\\(osd-reuse-id\\.sh.*$") "\n")
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index 4b026b93cb..91f4b3d0ed 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -35,14 +35,14 @@
(define-public owncloud-client
(package
(name "owncloud-client")
- (version "2.2.4")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://download.owncloud.com/desktop/stable/"
"owncloudclient-" version ".tar.xz"))
(sha256
- (base32 "1lz7v5sscj5489panz5ng372g9l66ng0srx6xaz8drnsgi7m64zk"))
+ (base32 "051rky4rpm73flxxkhfdxqq23ncnk4ixhscbg74w82sa4d93f54k"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -75,11 +75,9 @@
(("\\/\\$\\{APPLICATION_EXECUTABLE\\}\\\"") "\""))
#t))
(add-after 'unpack 'delete-failing-tests
- ;; These tests fail for no apparent reason
+ ;; "Could not create autostart folder"
(lambda _
(substitute* "test/CMakeLists.txt"
- (("owncloud_add_test\\(FileSystem \"\"\\)" test)
- (string-append "#" test))
(("owncloud_add_test\\(Utility \"\"\\)" test)
(string-append "#" test)))
#t)))
diff --git a/gnu/packages/synergy.scm b/gnu/packages/synergy.scm
index 7f8a30fa33..b971cbe3a9 100644
--- a/gnu/packages/synergy.scm
+++ b/gnu/packages/synergy.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,7 +34,7 @@
(define-public synergy
(package
(name "synergy")
- (version "1.8.2")
+ (version "1.8.8")
(source
(origin
(method url-fetch)
@@ -42,7 +43,7 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ym9lmnm64i1bw4spxq40drb4nvzsq5z7zq1935aq0kgccccg11g"))
+ "16vxbly4a33c63da3kmj7j47cam583l7bip33jc43mw173wqihw5"))
(modules '((guix build utils)))
(snippet
;; Remove ~14MB of unnecessary bundled source and binaries
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index fce47d93ce..c8786dd69b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
@@ -850,3 +852,33 @@ calendar applications. It also includes a panel clock plugin and an
international clock application capable of simultaneously showing clocks from
several different time zones.")
(license gpl2+)))
+
+(define-public xfce4-notifyd
+ (package
+ (name "xfce4-notifyd")
+ (version "0.3.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/apps/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1ybcfqfynr33g5hp2lgq17s8qyx7rq6fd2iwrpwcvm6kml6prjpl"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxfce4ui" ,libxfce4ui)
+ ("libnotify" ,libnotify)))
+ (home-page "https://goodies.xfce.org/projects/applications/xfce4-notifyd")
+ (synopsis "Show notification bubbles on Xfce")
+ (description
+ "The Xfce Notify Daemon (xfce4-notifyd for short) is a smallish program
+that implements the “server-side” portion of the Freedesktop desktop
+notifications specification. Applications that wish to pop up a notification
+bubble in a standard way can implicitly make use of xfce4-notifyd to do so by
+sending standard messages over D-Bus using the
+@code{org.freedesktop.Notifications} interface.")
+ (license gpl2)))
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 7460b5d85f..247107917d 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 humanitiesNerd <catonano@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1122,3 +1123,25 @@ files. It is designed to be fast and to handle large input files.")
"libxls is a C library which can read Excel (xls) files since Excel 97 (the BIFF8 format).
libxls cannot write Excel files.")
(license license:bsd-2)))
+
+(define-public freexl
+ (package
+ (name "freexl")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.gaia-gis.it/gaia-sins/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "17a0yrjb0gln7819j0vp7y25imhvwpil2b0rm44mwgzml0a4i6mk"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.gaia-gis.it/fossil/freexl/index")
+ (synopsis "Read Excel files")
+ (description
+ "FreeXL is a C library to extract valid data from within an Excel (.xls)
+spreadsheet.")
+ ;; Any of these licenses may be picked.
+ (license (list license:gpl2+
+ license:lgpl2.1+
+ license:mpl1.1))))