summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 67449c02d2..c78f2fe533 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1013,15 +1013,15 @@ and should be used with caution, especially on untested models.")
#t))))
(build-system linux-module-build-system)
(arguments
- `(#:phases
+ `(#:make-flags
+ (list (string-append "KSRC="
+ (assoc-ref %build-inputs "linux-module-builder")
+ "/lib/modules/build"))
+ #:phases
(modify-phases %standard-phases
(replace 'build
- (lambda* (#:key inputs make-flags #:allow-other-keys)
- (apply invoke "make"
- (string-append "KSRC="
- (assoc-ref inputs "linux-module-builder")
- "/lib/modules/build")
- (or make-flags '())))))
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" make-flags))))
#:tests? #f)) ; no test suite
(supported-systems '("x86_64-linux" "i686-linux"))
(home-page "https://github.com/aircrack-ng/rtl8812au")