summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rw-r--r--emacs.am3
2 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 768a8bd263..2fa126959a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -484,3 +484,7 @@ AM_V_DL_0 = @echo " DL " $@;
AM_V_DOT = $(AM_V_DOT_$(V))
AM_V_DOT_ = $(AM_V_DOT_$(AM_DEFAULT_VERBOSITY))
AM_V_DOT_0 = @echo " DOT " $@;
+
+AM_V_EMACS = $(AM_V_EMACS_$(V))
+AM_V_EMACS_ = $(AM_V_EMACS_$(AM_DEFAULT_VERBOSITY))
+AM_V_EMACS_0 = @echo " EMACS " $@;
diff --git a/emacs.am b/emacs.am
index 6af9596ce9..30bb02b454 100644
--- a/emacs.am
+++ b/emacs.am
@@ -1,5 +1,6 @@
# GNU Guix --- Functional package management for GNU
# Copyright © 2014, 2015, 2016 Alex Kost <alezost@gmail.com>
+# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
#
# This file is part of GNU Guix.
#
@@ -60,7 +61,7 @@ dist_lisp_DATA = \
nodist_lisp_DATA = emacs/guix-config.el
$(AUTOLOADS): $(ELFILES)
- $(EMACS) --batch --eval \
+ $(AM_V_EMACS)$(EMACS) --batch --eval \
"(let ((backup-inhibited t) \
(generated-autoload-file \
(expand-file-name \"$(AUTOLOADS)\" \"$(srcdir)\"))) \