summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/node.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 7dc6317d1d..c85e10454a 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -289,6 +289,38 @@ devices.")
milliseconds.")
(license license:expat)))
+(define-public node-binary-search-bootstrap
+ (package
+ (name "node-binary-search")
+ (version "1.3.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/darkskyapp/binary-search.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xr2msdc143cd3xwgq7n3rhzy7j8wrnaidxl0r6l6b6g3mpbpjig"))))
+ (build-system node-build-system)
+ (arguments
+ `(#:node ,node-bootstrap
+ #:tests? #f
+ #:phases
+ (modify-phases
+ %standard-phases
+ (delete 'configure)
+ (delete 'build))))
+ (home-page
+ "https://github.com/darkskyapp/binary-search#readme")
+ (properties '((hidden? . #t)))
+ (synopsis
+ "Tiny binary search function with comparators")
+ (description
+ "This package is a binary search function for @code{Node.js}.")
+ (license license:cc0)))
+
(define-public libnode
(package
(inherit node)