summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ff789ffedf..c6d95d9b83 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -959,8 +959,13 @@ replacement.")
;; native input.
(lambda _
(with-directory-excursion "tests"
+ ;; File `haskell-indent-tests.el' fails with
+ ;; `haskell-indent-put-region-in-literate-2'
+ ;; on Emacs 27.1+
+ ;; XXX: https://github.com/haskell/haskell-mode/issues/1714
(for-each delete-file
- '("haskell-customize-tests.el"
+ '("haskell-indent-tests.el"
+ "haskell-customize-tests.el"
"inferior-haskell-tests.el")))
#t))
(replace 'install