summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 18d83d89f3..cce059641c 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -891,6 +891,50 @@ cards.")
"Kommit is a git client for KDE.")
(license license:gpl3+)))
+(define-public kompare
+ (package
+ (name "kompare")
+ (version "23.04.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/kompare-" version ".tar.xz"))
+ (sha256
+ (base32
+ "058rr0n5r9czxqs6ixacx0bm8hglwjmhfpf5xf1zr0fjgcirlrwy"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules kdoctools))
+ (inputs
+ (list libkomparediff2
+ kcodecs
+ kconfig
+ kcoreaddons
+ kiconthemes
+ kjobwidgets
+ kparts
+ ktexteditor
+ kwidgetsaddons))
+ (home-page "https://apps.kde.org/kompare/")
+ (synopsis "Graphical file differences tool")
+ (description
+ "Kompare is a program to view the differences between files. Features
+include:
+@itemize
+@item comparison of files or directories via a graphical interface,
+@item bezier-based connection widget letting you see both source and destination,
+@item graphical viewing of patch files in normal, context, unified and diff
+ formats,
+@item interactive application of differences,
+@item network transparency,
+@item ability to view plain-text diff output in embedded viewer,
+@item navigation of multiple-file diffs with dockable navigation tree,
+@item graphical interface for commonly used diff command line options,
+@item switch source and destination
+@item and diff statistics.
+@end itemize")
+ (license license:gpl3+)))
+
(define-public kopeninghours
(package
(name "kopeninghours")