summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm11
-rw-r--r--gnu/packages/patches/nautilus-disable-tracker-tests.patch47
3 files changed, 8 insertions, 51 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bc4594146a..cd41e6794d 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1537,7 +1537,6 @@ dist_patch_DATA = \
%D%/packages/patches/musl-cross-locale.patch \
%D%/packages/patches/mutt-store-references.patch \
%D%/packages/patches/m4-gnulib-libio.patch \
- %D%/packages/patches/nautilus-disable-tracker-tests.patch \
%D%/packages/patches/ncompress-fix-softlinks.patch \
%D%/packages/patches/ncftp-reproducible.patch \
%D%/packages/patches/netcdf-date-time.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cc8e2a0396..5a3ae2659d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9519,15 +9519,20 @@ shared object databases, search tools and indexing.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))
- (patches
- (search-patches "nautilus-disable-tracker-tests.patch"))))
+ "1cncyiyh79w1id6a6s2f0rxmgwl65lp4ml4afa0z35jrnwp2s8cr"))))
(build-system meson-build-system)
(arguments
(list
#:glib-or-gtk? #t
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-tracker-tests
+ ;; The tracker test hangs in the build container (see:
+ ;; https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
+ (lambda _
+ (substitute* "test/automated/displayless/meson.build"
+ (("^foreach t: tracker_tests" all)
+ (string-append "tracker_tests = []\n" all)))))
(add-after 'unpack 'make-extensible
(lambda _
(substitute* "src/nautilus-module.c"
diff --git a/gnu/packages/patches/nautilus-disable-tracker-tests.patch b/gnu/packages/patches/nautilus-disable-tracker-tests.patch
deleted file mode 100644
index bcc7b38f33..0000000000
--- a/gnu/packages/patches/nautilus-disable-tracker-tests.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-The tracker test hangs in the build container (see:
-https://gitlab.gnome.org/GNOME/nautilus/-/issues/2486).
-
---- a/test/automated/displayless/meson.build 2022-09-10 00:52:50.348405729 -0400
-+++ b/test/automated/displayless/meson.build 2022-09-10 00:53:07.267907525 -0400
-@@ -34,41 +34,3 @@
- 'test-file-operations-trash-or-delete.c'
- ]]
- ]
--
--tracker_tests = [
-- ['test-nautilus-search-engine-tracker', [
-- 'test-nautilus-search-engine-tracker.c',
-- ]],
--]
--
--foreach t: tests
-- test(
-- t[0],
-- executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep),
-- env: [
-- test_env,
-- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
-- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
-- ],
-- timeout: 480
-- )
--endforeach
--
--
--
--# Tests that read and write from the Tracker index are run using 'tracker-sandbox'
--# script to use a temporary instance of tracker-miner-fs instead of the session one.
--foreach t: tracker_tests
-- test_exe = executable(t[0], t[1], files('test-utilities.c'), dependencies: libnautilus_dep)
-- test(
-- t[0],
-- tracker_sandbox,
-- args: ['--store-tmpdir', '--index-recursive-tmpdir', test_exe],
-- env: [
-- test_env,
-- 'G_TEST_BUILDDIR=@0@'.format(meson.current_build_dir()),
-- 'G_TEST_SRCDIR=@0@'.format(meson.current_source_dir())
-- ],
-- timeout: 480
-- )
--endforeach