summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gd.scm3
-rw-r--r--gnu/packages/patches/gd-fix-gd2-read-test.patch14
3 files changed, 1 insertions, 17 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 473197078d..a0d9b8fe11 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -514,7 +514,6 @@ dist_patch_DATA = \
%D%/packages/patches/gcc-cross-environment-variables.patch \
%D%/packages/patches/gcc-libvtv-runpath.patch \
%D%/packages/patches/gcc-5.0-libvtv-runpath.patch \
- %D%/packages/patches/gd-fix-gd2-read-test.patch \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gegl-CVE-2012-4433.patch \
%D%/packages/patches/geoclue-config.patch \
diff --git a/gnu/packages/gd.scm b/gnu/packages/gd.scm
index b1bbc22cd7..153e1c7f8b 100644
--- a/gnu/packages/gd.scm
+++ b/gnu/packages/gd.scm
@@ -50,8 +50,7 @@
(sha256
(base32
"0g3xz8jpz1pl2zzmssglrpa9nxiaa7rmcmvgpbrjz8k9cyynqsvl"))
- (patches (search-patches "gd-fix-gd2-read-test.patch"
- "gd-fix-tests-on-i686.patch"))))
+ (patches (search-patches "gd-fix-tests-on-i686.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/gd-fix-gd2-read-test.patch b/gnu/packages/patches/gd-fix-gd2-read-test.patch
deleted file mode 100644
index 65f39e4426..0000000000
--- a/gnu/packages/patches/gd-fix-gd2-read-test.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Fix a 'maybe-uninitialized' warning (turned error)
-which occurs on non-Intel platforms.
-
---- libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-21 01:21:16.000000000 -0400
-+++ libgd-2.2.3/tests/gd2/gd2_read.c 2016-07-29 15:52:03.806405312 -0400
-@@ -5,7 +5,7 @@
-
- int main(int argc, char *argv[])
- {
-- int error, i = 0;
-+ int error = 0, i = 0;
- gdImagePtr im, exp;
- FILE *fp;
- char *path[] = {