summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bdw-gc.scm7
-rw-r--r--gnu/packages/guile.scm16
2 files changed, 5 insertions, 18 deletions
diff --git a/gnu/packages/bdw-gc.scm b/gnu/packages/bdw-gc.scm
index db01d1a7e2..4b7099ffcd 100644
--- a/gnu/packages/bdw-gc.scm
+++ b/gnu/packages/bdw-gc.scm
@@ -34,7 +34,7 @@
(define-public libgc
(package
(name "libgc")
- (version "8.0.6")
+ (version "8.2.2")
(source (origin
(method url-fetch)
(uri (list (string-append "https://github.com/ivmai/bdwgc/releases"
@@ -44,7 +44,7 @@
"/gc-" version ".tar.gz")))
(sha256
(base32
- "04ga3c95w5az5sznzm73j19lvvfpf6k4sgkpjqsmjxpsr6mi8j9v"))))
+ "181ni2rn9qjbl4ilqdjrd1a4h8siv5bgmzqgg4595q32n2y0f0gk"))))
(build-system gnu-build-system)
(arguments
(list
@@ -53,9 +53,6 @@
;; Install gc_cpp.h et al.
"--enable-cplusplus"
- ;; Work around <https://github.com/ivmai/bdwgc/issues/353>.
- "--disable-munmap"
-
;; In GNU/Hurd systems during the 'check' phase,
;; there is a deadlock caused by the 'gctest' test.
;; To disable the error set "--disable-gcj-support"
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 32faa8c020..d1b8f70f47 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -325,11 +325,8 @@ without requiring the source code to be rewritten.")
(patches '())
;; Replace the snippet because the oom-test still
;; fails on some 32-bit architectures.
- (snippet '(begin
- (substitute* "test-suite/standalone/Makefile.in"
- (("test-out-of-memory") ""))
- (for-each delete-file
- (find-files "prebuilt" "\\.go$"))))))
+ (snippet '(for-each delete-file
+ (find-files "prebuilt" "\\.go$")))))
;; Build with the bundled mini-GMP to avoid interference with GnuTLS' own
;; use of GMP via Nettle: <https://issues.guix.gnu.org/46330>.
@@ -448,10 +445,7 @@ without requiring the source code to be rewritten.")
(display ,version port)))))
(add-before 'check 'skip-failing-tests
(lambda _
- (substitute* "test-suite/standalone/test-out-of-memory"
- (("!#") "!#\n\n(exit 77)\n"))
- (delete-file "test-suite/tests/version.test")
- #t))))))
+ (delete-file "test-suite/tests/version.test")))))))
(native-inputs
(modify-inputs (package-native-inputs guile-3.0)
(prepend autoconf
@@ -575,10 +569,6 @@ GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
(substitute* "test-suite/tests/version.test"
(("\\(pass-if \"version reporting works\"" m)
(string-append "#;" m)))
- ;; Warning: Unwind-only `out-of-memory' exception; skipping pre-unwind handler.
- ;; FAIL: test-out-of-memory
- (substitute* "test-suite/standalone/Makefile.am"
- (("(check_SCRIPTS|TESTS) \\+= test-out-of-memory") ""))
(patch-shebang "build-aux/git-version-gen")
(invoke "sh" "autogen.sh")