summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp-xyz.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 84ee45b4c9..93cc728dce 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -1281,27 +1281,40 @@ timeouts.")
(define-public sbcl-bordeaux-threads
(package
(name "sbcl-bordeaux-threads")
- (version "0.8.8")
+ (version "0.9.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/sionescu/bordeaux-threads")
(commit (string-append "v" version))))
(sha256
- (base32 "19i443fz3488v1pbbr9x24y8h8vlyhny9vj6c9jk5prm702awrp6"))
- (file-name
- (git-file-name "bordeaux-threads" version))))
- (inputs (list sbcl-alexandria))
+ (base32 "0d9sd7pm91yhln95z8nclhn6n4l5b2cp3pxpggpmpv7rsq84ssmh"))
+ (file-name (git-file-name "cl-bordeaux-threads" version))))
+ (inputs (list sbcl-alexandria
+ sbcl-global-vars
+ sbcl-trivial-features
+ sbcl-trivial-garbage))
(native-inputs (list sbcl-fiveam))
(build-system asdf-build-system/sbcl)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (add-after 'unpack 'silence-deprecation-warning
+ (lambda _
+ ;; The deprecation warning for APIv1 makes the build of some
+ ;; of the dependents of bordeaux-threads fail because they
+ ;; interpret it as an error instead of a simple indication.
+ ;; Let's silence this warning for now.
+ (substitute* (cons* "apiv1/default-implementations.lisp"
+ (find-files "apiv1" "impl-.*\\.lisp"))
+ (("\\(warn \"Bordeaux-Threads APIv1 is deprecated\\. Please migrate to APIv2\\.\"\\)")
+ ""))))
(add-after 'unpack 'adjust-test-sleep
(lambda _
;; 0.001 is too short for some slower machines.
- (substitute* "test/bordeaux-threads-test.lisp"
+ (substitute* '("test/tests-v1.lisp"
+ "test/tests-v2.lisp")
(("sleep 0\\.001") "sleep 0.002")))))))
(synopsis "Portable shared-state concurrency library for Common Lisp")
(description "BORDEAUX-THREADS is a proposed standard for a minimal