summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch13
-rw-r--r--gnu/packages/tex.scm3
3 files changed, 16 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4cf006dd60..872437cb42 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1851,6 +1851,7 @@ dist_patch_DATA = \
%D%/packages/patches/telegram-purple-adjust-test.patch \
%D%/packages/patches/texi2html-document-encoding.patch \
%D%/packages/patches/texi2html-i18n.patch \
+ %D%/packages/patches/texlive-hyph-utf8-no-byebug.patch \
%D%/packages/patches/thefuck-test-environ.patch \
%D%/packages/patches/tidy-CVE-2015-5522+5523.patch \
%D%/packages/patches/timescaledb-flaky-test.patch \
diff --git a/gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch b/gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch
new file mode 100644
index 0000000000..fb29b76ef2
--- /dev/null
+++ b/gnu/packages/patches/texlive-hyph-utf8-no-byebug.patch
@@ -0,0 +1,13 @@
+Description: Avoid dependency on byebug to reduce package closure
+ significantly, see https://issues.guix.gnu.org/55997
+diff --git a/lib/tex/hyphen/language.rb b/lib/tex/hyphen/language.rb
+index 12831417..df6daa39 100644
+--- a/lib/tex/hyphen/language.rb
++++ b/lib/tex/hyphen/language.rb
+@@ -1,6 +1,5 @@
+ require 'yaml'
+ require 'hydra'
+-require 'byebug'
+
+ require_relative 'path'
+
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ddcd0043c4..d075a6e475 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -157,6 +157,7 @@ copied to their outputs; otherwise the TEXLIVE-BUILD-SYSTEM is used."
(file-name (string-append "hyph-utf8-scripts-"
(number->string %texlive-revision)
"-checkout"))
+ (patches (search-patches "texlive-hyph-utf8-no-byebug.patch"))
(sha256
(base32
"04xzf5gr3ylyh3ls09imrx4mwq3qp1k97r9njzlan6hlff875rx2"))))
@@ -225,7 +226,7 @@ files from LOCATIONS with expected checksum HASH. CODE is not currently in use.
(invoke "ruby" "generate-ptex-patterns.rb")))))))))
(native-inputs
`(("ruby" ,ruby)
- ("ruby-hydra" ,ruby-hydra)
+ ("ruby-hydra-minimal" ,ruby-hydra-minimal)
("hyph-utf8-scripts" ,hyph-utf8-scripts)))
(home-page "https://ctan.org/pkg/hyph-utf8"))))