summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index b7d15d0730..e3ce0069f0 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -88,6 +88,11 @@ where the OS part is overloaded to denote a specific ABI---into GCC
(string-prefix? "powerpc-" target))
'("--with-long-double-128"))
+ ;; GCC 11.3.0's <libgcov.h> includes <sys/mman.h>, which MinGW lacks:
+ ;; <https://bugs.gentoo.org/show_bug.cgi?id=843989>.
+ ((target-mingw? target)
+ '("--disable-gcov"))
+
(else
;; TODO: Add `arm.*-gnueabi', etc.
'())))