summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm110
-rw-r--r--gnu/packages/crates-tls.scm111
2 files changed, 111 insertions, 110 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index cc0974aeda..506f1f1d75 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -53954,116 +53954,6 @@ Rust.")
(description "This package provides core APIs for Rayon.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-rcgen-0.11
- (package
- (name "rust-rcgen")
- (version "0.11.3")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "rcgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1iivv3xycr9mjfmp522xjqj47nsl5amlzzsfpbxpvg53984g7i2j"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Don't use a vendored botan.
- (substitute* "Cargo.toml"
- ((".*vendored.*") ""))))))
- (build-system cargo-build-system)
- (arguments
- `(#:cargo-inputs
- (("rust-pem" ,rust-pem-3)
- ("rust-ring" ,rust-ring-0.16)
- ("rust-time" ,rust-time-0.3)
- ("rust-x509-parser" ,rust-x509-parser-0.15)
- ("rust-yasna" ,rust-yasna-0.5)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-botan" ,rust-botan-0.10)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rsa" ,rust-rsa-0.9)
- ("rust-rustls-webpki" ,rust-rustls-webpki-0.101)
- ("rust-x509-parser" ,rust-x509-parser-0.15))))
- (native-inputs
- (list pkg-config))
- (inputs
- (list botan openssl))
- (home-page "https://github.com/rustls/rcgen")
- (synopsis "Rust X.509 certificate generator")
- (description "Rust X.509 certificate generator.")
- (license (list license:expat license:asl2.0))))
-
-(define-public rust-rcgen-0.10
- (package
- (inherit rust-rcgen-0.11)
- (name "rust-rcgen")
- (version "0.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "rcgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0nvqgr697xzdzaavkcwcl59kxw7xfx9zdhdzx49fm3gkwbpq9gpz"))
- (snippet
- #~(begin (use-modules (guix build utils))
- ;; Don't use a vendored botan.
- (substitute* "Cargo.toml"
- ((".*vendored.*") ""))))))
- (arguments
- `(#:cargo-inputs (("rust-pem" ,rust-pem-1)
- ("rust-ring" ,rust-ring-0.16)
- ("rust-time" ,rust-time-0.3)
- ("rust-x509-parser" ,rust-x509-parser-0.14)
- ("rust-yasna" ,rust-yasna-0.5)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs (("rust-botan" ,rust-botan-0.8)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rsa" ,rust-rsa-0.6)
- ("rust-webpki" ,rust-webpki-0.22)
- ("rust-x509-parser" ,rust-x509-parser-0.14))))))
-
-(define-public rust-rcgen-0.8
- (package
- (inherit rust-rcgen-0.11)
- (name "rust-rcgen")
- (version "0.8.14")
- (source (origin
- (method url-fetch)
- (uri (crate-uri "rcgen" version))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "19qvlcz8kl046q85xa40p3xg7l78jganj83hdbawjhs17x0d24ar"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Don't use a vendored botan.
- (substitute* "Cargo.toml"
- ((".*vendored.*") ""))))))
- (arguments
- `(#:cargo-test-flags
- '("--release" "--"
- "--skip=tests::test_dt_to_generalized"
- "--skip=tests::test_dt_utc_strip_nanos")
- #:cargo-inputs
- (("rust-chrono" ,rust-chrono-0.4)
- ("rust-pem" ,rust-pem-1)
- ("rust-ring" ,rust-ring-0.16)
- ("rust-x509-parser" ,rust-x509-parser-0.12)
- ("rust-yasna" ,rust-yasna-0.4)
- ("rust-zeroize" ,rust-zeroize-1))
- #:cargo-development-inputs
- (("rust-botan" ,rust-botan-0.8)
- ("rust-openssl" ,rust-openssl-0.10)
- ("rust-rand" ,rust-rand-0.8)
- ("rust-rsa" ,rust-rsa-0.5)
- ("rust-webpki" ,rust-webpki-0.22)
- ("rust-x509-parser" ,rust-x509-parser-0.12))))))
-
(define-public rust-rctree-0.5
(package
(name "rust-rctree")
diff --git a/gnu/packages/crates-tls.scm b/gnu/packages/crates-tls.scm
index c21d7f3048..99dbf8e013 100644
--- a/gnu/packages/crates-tls.scm
+++ b/gnu/packages/crates-tls.scm
@@ -36,6 +36,7 @@
#:use-module (gnu packages crates-io)
#:use-module (gnu packages crates-web)
#:use-module (gnu packages crates-windows)
+ #:use-module (gnu packages crypto)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages rust-apps)
#:use-module (gnu packages tls))
@@ -132,6 +133,116 @@
implementation.")
(license (list license:expat license:asl2.0))))
+(define-public rust-rcgen-0.11
+ (package
+ (name "rust-rcgen")
+ (version "0.11.3")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "rcgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1iivv3xycr9mjfmp522xjqj47nsl5amlzzsfpbxpvg53984g7i2j"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Don't use a vendored botan.
+ (substitute* "Cargo.toml"
+ ((".*vendored.*") ""))))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-pem" ,rust-pem-3)
+ ("rust-ring" ,rust-ring-0.16)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-x509-parser" ,rust-x509-parser-0.15)
+ ("rust-yasna" ,rust-yasna-0.5)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-botan" ,rust-botan-0.10)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rsa" ,rust-rsa-0.9)
+ ("rust-rustls-webpki" ,rust-rustls-webpki-0.101)
+ ("rust-x509-parser" ,rust-x509-parser-0.15))))
+ (native-inputs
+ (list pkg-config))
+ (inputs
+ (list botan openssl))
+ (home-page "https://github.com/rustls/rcgen")
+ (synopsis "Rust X.509 certificate generator")
+ (description "Rust X.509 certificate generator.")
+ (license (list license:expat license:asl2.0))))
+
+(define-public rust-rcgen-0.10
+ (package
+ (inherit rust-rcgen-0.11)
+ (name "rust-rcgen")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "rcgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0nvqgr697xzdzaavkcwcl59kxw7xfx9zdhdzx49fm3gkwbpq9gpz"))
+ (snippet
+ #~(begin (use-modules (guix build utils))
+ ;; Don't use a vendored botan.
+ (substitute* "Cargo.toml"
+ ((".*vendored.*") ""))))))
+ (arguments
+ `(#:cargo-inputs (("rust-pem" ,rust-pem-1)
+ ("rust-ring" ,rust-ring-0.16)
+ ("rust-time" ,rust-time-0.3)
+ ("rust-x509-parser" ,rust-x509-parser-0.14)
+ ("rust-yasna" ,rust-yasna-0.5)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-botan" ,rust-botan-0.8)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rsa" ,rust-rsa-0.6)
+ ("rust-webpki" ,rust-webpki-0.22)
+ ("rust-x509-parser" ,rust-x509-parser-0.14))))))
+
+(define-public rust-rcgen-0.8
+ (package
+ (inherit rust-rcgen-0.11)
+ (name "rust-rcgen")
+ (version "0.8.14")
+ (source (origin
+ (method url-fetch)
+ (uri (crate-uri "rcgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "19qvlcz8kl046q85xa40p3xg7l78jganj83hdbawjhs17x0d24ar"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Don't use a vendored botan.
+ (substitute* "Cargo.toml"
+ ((".*vendored.*") ""))))))
+ (arguments
+ `(#:cargo-test-flags
+ '("--release" "--"
+ "--skip=tests::test_dt_to_generalized"
+ "--skip=tests::test_dt_utc_strip_nanos")
+ #:cargo-inputs
+ (("rust-chrono" ,rust-chrono-0.4)
+ ("rust-pem" ,rust-pem-1)
+ ("rust-ring" ,rust-ring-0.16)
+ ("rust-x509-parser" ,rust-x509-parser-0.12)
+ ("rust-yasna" ,rust-yasna-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs
+ (("rust-botan" ,rust-botan-0.8)
+ ("rust-openssl" ,rust-openssl-0.10)
+ ("rust-rand" ,rust-rand-0.8)
+ ("rust-rsa" ,rust-rsa-0.5)
+ ("rust-webpki" ,rust-webpki-0.22)
+ ("rust-x509-parser" ,rust-x509-parser-0.12))))))
+
(define-public rust-rustls-0.21
(package
(name "rust-rustls")