summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/guix.texi33
-rw-r--r--gnu/home/services/guix.scm44
-rw-r--r--gnu/local.mk1
3 files changed, 78 insertions, 0 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index 097e4a362b..a7ac74b416 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -105,6 +105,7 @@ Copyright @copyright{} 2022 Aleksandr Vityazev@*
Copyright @copyright{} 2022 Philip M@sup{c}Grath@*
Copyright @copyright{} 2022 Karl Hallsby@*
Copyright @copyright{} 2022 Justin Veilleux@*
+Copyright @copyright{} 2022 Reily Siegel@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -39433,6 +39434,7 @@ services)}.
* Shepherd: Shepherd Home Service. Managing User's Daemons.
* SSH: Secure Shell. Setting up the secure shell client.
* Desktop: Desktop Home Services. Services for graphical environments.
+* Guix: Guix Home Services. Services for Guix.
@end menu
@c In addition to that Home Services can provide
@@ -40073,6 +40075,37 @@ format.
@end deftp
+@node Guix Home Services
+@subsection Guix Home Services
+
+The @code{(gnu home services guix)} module provides services for
+user-specific Guix configuration.
+
+@defvr {Scheme Variable} home-channels-service-type
+This is the service type for managing
+@file{$XDG_CONFIG_HOME/guix/channels.scm}, the file that controls the
+channels received on @command{guix pull} (@pxref{Channels}). Its
+associated value is a list of @code{channel} records, defined in the
+@code{(guix channels)} module.
+
+Generally, it is better to extend this service than to directly
+configure it, as its default value is the default guix channel(s)
+defined by @code{%default-channels}. If you configure this service
+directly, be sure to include a guix channel. @xref{Specifying
+Additional Channels} and @ref{Using a Custom Guix Channel} for more
+details.
+
+A typical extension for adding a channel might look like this:
+
+@lisp
+(simple-service 'variant-packages-service
+ home-channels-service-type
+ (list
+ (channel
+ (name 'variant-packages)
+ (url "https://example.org/variant-packages.git")))
+@end lisp
+@end defvr
@node Invoking guix home
@section Invoking @code{guix home}
diff --git a/gnu/home/services/guix.scm b/gnu/home/services/guix.scm
new file mode 100644
index 0000000000..819b20b6c9
--- /dev/null
+++ b/gnu/home/services/guix.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Reily Siegel <mail@reilysiegel.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home services guix)
+ #:use-module (gnu home services)
+ #:use-module (guix channels)
+ #:use-module (guix gexp)
+ #:use-module (ice-9 pretty-print)
+ #:use-module (srfi srfi-1)
+ #:export (home-channels-service-type))
+
+(define (channels-xdg-files channels)
+ `(("guix/channels.scm"
+ ,(plain-file
+ "channels.scm"
+ (call-with-output-string
+ (lambda (port)
+ (pretty-print (cons 'list (map channel->code channels)) port)))))))
+
+(define home-channels-service-type
+ (service-type
+ (name 'home-channels)
+ (default-value %default-channels)
+ (compose concatenate)
+ (extend append)
+ (extensions
+ (list (service-extension home-xdg-configuration-files-service-type
+ channels-xdg-files)))
+ (description "Manages the per-user Guix channels specification.")))
diff --git a/gnu/local.mk b/gnu/local.mk
index 12b04d2c2d..6d30109a35 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -83,6 +83,7 @@ GNU_SYSTEM_MODULES = \
%D%/home/services/desktop.scm \
%D%/home/services/symlink-manager.scm \
%D%/home/services/fontutils.scm \
+ %D%/home/services/guix.scm \
%D%/home/services/shells.scm \
%D%/home/services/shepherd.scm \
%D%/home/services/ssh.scm \