summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm94
-rw-r--r--gnu/packages/patches/emacs-telega-path-placeholder.patch41
2 files changed, 68 insertions, 67 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index dfbd51ac0a..95f218e55d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30976,52 +30976,54 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
(license license:gpl3+)))
(define-public emacs-telega-server
- (package
- (name "emacs-telega-server")
- (version "0.8.03")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/zevlg/telega.el")
- (commit (string-append "v" version))))
- (sha256
- (base32 "1ffy17i5fi1bw5r5m6x372c52hc1k83wxdxvi4z0hixyklj48nsv"))
- (file-name (git-file-name "emacs-telega" version))
- (patches
- (search-patches "emacs-telega-path-placeholder.patch"
- "emacs-telega-test-env.patch"))))
- (build-system gnu-build-system)
- (arguments
- (list
- #:make-flags
- #~(list (string-append "CC=" #$(cc-for-target))
- (string-append "INSTALL_PREFIX=" #$output "/bin"))
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'configure 'enter-subdirectory
- (lambda _ (chdir "server")))
- (replace 'configure
- (lambda _
- (substitute* "run_tests.py"
- (("^(TELEGA_SERVER = ).*$" _all prefix)
- (string-append prefix
- "\"" #$output "/bin/telega-server\"\n")))))
- (delete 'check)
- (add-after 'install 'check
- (assoc-ref %standard-phases 'check))
- (add-before 'install-license-files 'leave-subdirectory
- (lambda _ (chdir ".."))))
- #:test-target "test"))
- (inputs
- (list tdlib-1.8.0 libappindicator))
- (native-inputs
- (list python pkg-config))
- (home-page "https://zevlg.github.io/telega.el/")
- (synopsis "Server process of Telega")
- (description "Telega-server is helper program to interact with Telegram
+ (let ((commit "01e8f9e397bb18522b76d3bcdb74f5798e7c4999")
+ (revision "0"))
+ (package
+ (name "emacs-telega-server")
+ (version (git-version "0.8.03" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zevlg/telega.el")
+ (commit commit)))
+ (sha256
+ (base32 "0fv0czx61rsvgf9jnn8nvng7flnihnjhym73hli5fzfgdx15lam7"))
+ (file-name (git-file-name "emacs-telega" version))
+ (patches
+ (search-patches "emacs-telega-path-placeholder.patch"
+ "emacs-telega-test-env.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "INSTALL_PREFIX=" #$output "/bin"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'enter-subdirectory
+ (lambda _ (chdir "server")))
+ (replace 'configure
+ (lambda _
+ (substitute* "run_tests.py"
+ (("^(TELEGA_SERVER = ).*$" _all prefix)
+ (string-append prefix
+ "\"" #$output "/bin/telega-server\"\n")))))
+ (delete 'check)
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'install-license-files 'leave-subdirectory
+ (lambda _ (chdir ".."))))
+ #:test-target "test"))
+ (inputs
+ (list tdlib-1.8.0 libappindicator))
+ (native-inputs
+ (list python pkg-config))
+ (home-page "https://zevlg.github.io/telega.el/")
+ (synopsis "Server process of Telega")
+ (description "Telega-server is helper program to interact with Telegram
service, and connect it with Emacs via inter-process communication.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-telega
(package
@@ -31059,7 +31061,7 @@ service, and connect it with Emacs via inter-process communication.")
(substitute* "telega-customize.el"
(("@TELEGA_SERVER_BIN@")
(search-input-file inputs "/bin/telega-server")))
- (substitute* "telega-util.el"
+ (substitute* "telega-core.el"
(("@TELEGA_SHARE@")
(string-append (elpa-directory (assoc-ref outputs "out"))
"/etc"))))))))
diff --git a/gnu/packages/patches/emacs-telega-path-placeholder.patch b/gnu/packages/patches/emacs-telega-path-placeholder.patch
index 5829edd22a..07ab8c1e66 100644
--- a/gnu/packages/patches/emacs-telega-path-placeholder.patch
+++ b/gnu/packages/patches/emacs-telega-path-placeholder.patch
@@ -1,18 +1,31 @@
-From bf95de21faa623e48bca00d6a2c9b33ab2c5d812 Mon Sep 17 00:00:00 2001
+From bfcd616f2870c8c3ffc9a526fcd574eb5e726a96 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
-Date: Wed, 8 Dec 2021 11:01:31 +0300
-Subject: [PATCH] Use absolute path for telega-server-command.
+Date: Sat, 14 Jan 2023 09:33:34 +0400
+Subject: [PATCH] Add path placeholder for telega-server-command and etc-file.
---
+ telega-core.el | 2 +-
telega-customize.el | 2 +-
- telega-util.el | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
+diff --git a/telega-core.el b/telega-core.el
+index 36f121e..f9f7976 100644
+--- a/telega-core.el
++++ b/telega-core.el
+@@ -41,7 +41,7 @@
+
+ (defun telega-etc-file (filename)
+ "Return absolute path to FILENAME from etc/ directory in telega."
+- (expand-file-name (concat "etc/" filename) telega--lib-directory))
++ (concat "@TELEGA_SHARE@" "/" filename))
+
+ (defconst telega-spoiler-translation-table
+ (let ((table (make-char-table 'translation-table)))
diff --git a/telega-customize.el b/telega-customize.el
-index 0af343f..cc2938c 100644
+index 0efb001..77cec5f 100644
--- a/telega-customize.el
+++ b/telega-customize.el
-@@ -591,7 +591,7 @@ In range [1..3]. Use 1."
+@@ -633,7 +633,7 @@ In range [1..3]. Use 1."
:prefix "telega-server-"
:group 'telega)
@@ -21,19 +34,5 @@ index 0af343f..cc2938c 100644
"Command to run as telega server.
It should be absolute path or binary file searchable in `exec-path'."
:type 'string
-diff --git a/telega-util.el b/telega-util.el
-index 6340c27..01e3cb7 100644
---- a/telega-util.el
-+++ b/telega-util.el
-@@ -587,7 +587,7 @@ N can't be 0."
-
- (defun telega-etc-file (filename)
- "Return absolute path to FILENAME from etc/ directory in telega."
-- (expand-file-name (concat "etc/" filename) telega--lib-directory))
-+ (concat "@TELEGA_SHARE@" "/" filename))
-
- (defun telega-link-props (link-type link-to &optional face)
- "Generate props for link button openable with `telega-link--button-action'."
--
-2.34.0
-
+2.38.1