summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/commencement.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 6fc224f9c8..c42185728c 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3402,9 +3402,19 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
(arguments
`(#:guile ,%bootstrap-guile
#:implicit-inputs? #f
- #:allowed-references ("out" ,glibc-final)
+ #:allowed-references
+ ,@(match (%current-system)
+ ("powerpc-linux"
+ `(("out" ,glibc-final ,static-bash-for-glibc)))
+ (_
+ `(("out" ,glibc-final))))
,@(package-arguments binutils)))
- (inputs (%boot2-inputs))))
+ (inputs
+ (match (%current-system)
+ ("powerpc-linux"
+ `(("bash" ,static-bash-for-glibc)
+ ,@(%boot2-inputs)))
+ (_ (%boot2-inputs))))))
(define libstdc++
;; Intermediate libstdc++ that will allow us to build the final GCC