summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ocaml.scm27
-rw-r--r--gnu/packages/patches/ocaml-graph-honor-source-date-epoch.patch34
3 files changed, 62 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index e4c25bf12e..edd6d8237e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -894,6 +894,7 @@ dist_patch_DATA = \
%D%/packages/patches/ocaml-CVE-2015-8869.patch \
%D%/packages/patches/ocaml-Add-a-.file-directive.patch \
%D%/packages/patches/ocaml-findlib-make-install.patch \
+ %D%/packages/patches/ocaml-graph-honor-source-date-epoch.patch \
%D%/packages/patches/omake-fix-non-determinism.patch \
%D%/packages/patches/ola-readdir-r.patch \
%D%/packages/patches/openscenegraph-ffmpeg3.patch \
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f49deb67a4..52294d10da 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3391,6 +3391,33 @@ unique identifiers (UUIDs) version 3, 5 (named based with MD5, SHA-1 hashing)
and 4 (random based) according to RFC 4122.")
(license license:isc)))
+(define-public ocaml-graph
+ (package
+ (name "ocaml-graph")
+ (version "1.8.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://ocamlgraph.lri.fr/download/"
+ "ocamlgraph-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1845r537swjil2fcj7lgbibc2zybfwqqasrd2s7bncajs83cl1nz"))
+ (patches (search-patches "ocaml-graph-honor-source-date-epoch.patch"))))
+ (build-system ocaml-build-system)
+ (arguments
+ `(#:install-target "install-findlib"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'set-shell
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CONFIG_SHELL" (string-append (assoc-ref inputs "bash")
+ "/bin/sh")))))))
+ (inputs `(("lablgtk" ,lablgtk)))
+ (home-page "http://ocamlgraph.lri.fr/")
+ (synopsis "Graph library for OCaml")
+ (description "OCamlgraph is a generic graph library for OCaml.")
+ (license license:lgpl2.1)))
+
(define-public coq-flocq
(package
(name "coq-flocq")
diff --git a/gnu/packages/patches/ocaml-graph-honor-source-date-epoch.patch b/gnu/packages/patches/ocaml-graph-honor-source-date-epoch.patch
new file mode 100644
index 0000000000..9f8713e3d3
--- /dev/null
+++ b/gnu/packages/patches/ocaml-graph-honor-source-date-epoch.patch
@@ -0,0 +1,34 @@
+From 354ef78aac0b887fae3c10b28eb2b0d83f66bdfe Mon Sep 17 00:00:00 2001
+From: Julien Lepiller <julien@lepiller.eu>
+Date: Mon, 2 Jan 2017 17:05:24 +0100
+Subject: [PATCH] Honor SOURCE_DATE_EPOCH
+
+---
+ Makefile.in | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index a32b4b8..ef4c174 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -113,11 +113,16 @@ graph.cmx: $(CMI) $(CMX)
+ $(OCAMLOPT) $(INCLUDES) -pack -o $@ $^
+
+ VERSION=1.8.7
++ifdef SOURCE_DATE_EPOCH
++BUILD_DATE=$(shell date -u -d "@$(SOURCE_DATE_EPOCH)" 2>/dev/null || date -u -r "$(SOURCE_DATE_EPOCH)" 2>/dev/null || date)
++else
++BUILD_DATE=$(shell date)
++endif
+
+ src/version.ml: Makefile
+ rm -f $@
+ echo "let version = \""$(VERSION)"\"" > $@
+- echo "let date = \""`date`"\"" >> $@
++ echo "let date = \""$(BUILD_DATE)"\"" >> $@
+
+ # gtk2 graph editor
+ ###################
+--
+2.11.0
+