summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 022dd23186..374fba982b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25706,6 +25706,21 @@ function.")
python-pandas))
(propagated-inputs (list python-decopatch python-makefun python-six))))
+(define-public python-pytest-steps
+ (package
+ (inherit python-pytest-steps-minimal)
+ (name "python-pytest-steps")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'move-pytests-plugins
+ (lambda _
+ (rename-file "pytest_steps/tests/conftest.py"
+ "conftest.py"))))))
+ (native-inputs (list python-pytest python-pytest-runner
+ python-setuptools-scm python-pytest-cases
+ python-pytest-harvest))))
+
(define-public python-frozendict
(package
(name "python-frozendict")