summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/astronomy.scm41
-rw-r--r--gnu/packages/education.scm38
2 files changed, 24 insertions, 55 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 799b5fe031..73fbb09d10 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -118,24 +118,31 @@ programs for the manipulation and analysis of astronomical data.")
(package
(name "stellarium")
(version "0.15.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/stellarium/Stellarium-sources/"
- version "/stellarium-" version ".tar.gz"))
- (sha256
- (base32
- "04avigz8i8mi2x6x71bqr9np85n1p9qnvbj2hxr947f1jv22zr8g"))))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/stellarium/"
+ "Stellarium-sources/"
+ version "/stellarium-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04avigz8i8mi2x6x71bqr9np85n1p9qnvbj2hxr947f1jv22zr8g"))))
(build-system cmake-build-system)
- (arguments
- `(#:tests? #f)) ; There are no tests.
- (home-page "https://www.gnu.org/software/stellarium")
(inputs `(("qt" ,qt)
("zlib" ,zlib)))
- (native-inputs `(("gettext" ,gettext-minimal)
- ("perl" ,perl)))
- (synopsis "Nocturnal sky renderering program")
- (description "Stellarium renders a realistic image of the sky in real time.
-With Stellarium, you really see what you can see with your eyes, binoculars or a
-small telescope.")
+ (native-inputs `(("gettext" ,gettext-minimal) ; xgettext is used at compile time
+ ("perl" ,perl))) ; For pod2man
+ (arguments
+ `(#:test-target "tests"
+ #:phases (modify-phases %standard-phases
+ (add-before 'check 'set-offscreen-display
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (home-page "http://www.stellarium.org/")
+ (synopsis "3D sky viewer")
+ (description "Stellarium is a planetarium. It shows a realistic sky in
+3D, just like what you see with the naked eye, binoculars, or a telescope. It
+can be used to control telescopes over a serial port for tracking celestial
+objects.")
(license license:gpl2+)))
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 5444579059..808be203c2 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -43,44 +43,6 @@
#:use-module (guix build-system cmake)
#:use-module (srfi srfi-1))
-(define-public stellarium
- (package
- (name "stellarium")
- (version "0.14.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/stellarium/"
- "Stellarium-sources/"
- version "/stellarium-" version ".tar.gz"))
- (sha256 (base32
- "1xxil0rv61zc08znfv83cpsc47y1gjl2f3njhz0pn5zd8jpaa15a"))))
- (build-system cmake-build-system)
- (inputs
- `(("qtbase" ,qtbase)
- ("zlib" ,zlib)
- ("qtserialport" ,qtserialport)
- ("qtscript" ,qtscript)
- ("gettext" ,gettext-minimal)))
- (native-inputs
- `(("qtbase" ,qtbase) ;Qt MOC is needed at compile time
- ("qttools" ,qttools)
- ("perl" ,perl))) ;for 'pod2man'
- (arguments
- `(#:test-target "tests"
- #:phases (modify-phases %standard-phases
- (add-before 'check 'set-offscreen-display
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "HOME" "/tmp")
- #t)))))
- (home-page "http://www.stellarium.org/")
- (synopsis "3D sky viewer")
- (description "Stellarium is a planetarium. It shows a realistic sky in
-3D, just like what you see with the naked eye, binoculars, or a telescope. It
-can be used to control telescopes over a serial port for tracking celestial
-objects.")
- (license license:gpl2+)))
-
(define-public gcompris
(package
(name "gcompris")