summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c7e5115802..c8a49040f4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5886,7 +5886,10 @@ services for numerous locations.")
"-Dsystemd=false"
;; Otherwise, the RUNPATH will lack the final path component.
(string-append "-Dc_link_args=-Wl,-rpath=" #$output
- "/lib/gnome-settings-daemon-3.0"))
+ "/lib/gnome-settings-daemon-3.0:"
+ ;; Also add NSS because for some reason Meson
+ ;; > 0.60 does not add it automatically (XXX).
+ (search-input-directory %build-inputs "lib/nss")))
#:phases
#~(modify-phases %standard-phases
(add-before 'configure 'set-baobab-file-name