summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 556f813396..213acc6b9f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5841,6 +5841,14 @@ The Flag. You can even design your own maps!")
(list "--with-system-enet")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-with-new-gcc
+ (lambda _
+ ;; Fix build with GCC6 and later by avoiding comparing ifstream
+ ;; to NULL. Can be removed for versions > 1.21.
+ (substitute* "src/lev/Proxy.cc"
+ (("ifs != NULL")
+ "ifs"))
+ #t))
(add-after 'unpack 'find-sdl
(lambda _
(substitute* "configure"