summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tree-sitter.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/tree-sitter.scm b/gnu/packages/tree-sitter.scm
index 65331cee65..7515461993 100644
--- a/gnu/packages/tree-sitter.scm
+++ b/gnu/packages/tree-sitter.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2022 muradm <mail@muradm.net>
;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
-;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023, 2024 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023 Raven Hallsby <karl@hallsby.com>
;;;
@@ -592,6 +592,17 @@ which will be used as a snippet in origin."
"0.7.1"
#:repository-url "https://github.com/ikatyang/tree-sitter-markdown"))
+(define-public tree-sitter-matlab
+ (let ((commit "79d8b25f57b48f83ae1333aff6723b83c9532e37")
+ (revision "0"))
+ (tree-sitter-grammar
+ "matlab" "Matlab"
+ "04ffhfnznskkcp91fbnv8jy3wkb9cd8ifwrkrdwcw74n1b2hq80c"
+ (git-version "1.0.2" revision commit)
+ #:repository-url "https://github.com/acristoffers/tree-sitter-matlab"
+ #:commit commit
+ #:license license:expat)))
+
(define-public tree-sitter-meson
;; tag 1.2 is Aug 24,2022 this commit is Feb 28,2023
(let ((commit "3d6dfbdb2432603bc84ca7dc009bb39ed9a8a7b1")