summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.gitignore1
-rw-r--r--Makefile.am9
2 files changed, 7 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 29879a5613..a211be9853 100644
--- a/.gitignore
+++ b/.gitignore
@@ -35,3 +35,4 @@ config.cache
/po/stamp-po
/po/guix.pot
/guix-build
+/tests/*.trs
diff --git a/Makefile.am b/Makefile.am
index a096c9b95d..8f8cb12c85 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -48,9 +48,12 @@ TESTS = \
tests/build-utils.scm \
tests/packages.scm
-TESTS_ENVIRONMENT = \
- NIXPKGS="$(NIXPKGS)" \
- GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH" \
+TESTS_ENVIRONMENT = \
+ NIXPKGS="$(NIXPKGS)"; \
+ GUILE_LOAD_COMPILED_PATH="$(top_builddir):$$GUILE_LOAD_COMPILED_PATH"; \
+ export NIXPKGS GUILE_LOAD_COMPILED_PATH;
+
+LOG_COMPILER = \
$(GUILE) --no-auto-compile -L "$(top_srcdir)"
EXTRA_DIST = build-aux/config.rpath $(TESTS)