summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 14 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 847d85052b..43f8c3fb82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -297,7 +297,7 @@ gnu/packages/bootstrap/i686-linux/guile-2.0.7.tar.xz:
nobase_nodist_guilemodule_DATA = $(GOBJECTS) guix/config.scm
-TESTS = \
+SCM_TESTS = \
tests/base32.scm \
tests/builders.scm \
tests/derivations.scm \
@@ -308,12 +308,16 @@ TESTS = \
tests/snix.scm \
tests/store.scm \
tests/nar.scm \
- tests/union.scm \
+ tests/union.scm
+
+SH_TESTS = \
tests/guix-build.sh \
tests/guix-download.sh \
tests/guix-gc.sh \
tests/guix-package.sh
+TESTS = $(SCM_TESTS) $(SH_TESTS)
+
TEST_EXTENSIONS = .scm .sh
AM_TESTS_ENVIRONMENT = abs_top_srcdir="$(abs_top_srcdir)"
@@ -340,12 +344,18 @@ EXTRA_DIST = \
release.nix \
$(TESTS)
-CLEANFILES = $(GOBJECTS) *.log
+CLEANFILES = \
+ $(GOBJECTS) \
+ $(SCM_TESTS:%.scm=%.log)
+
+AM_V_GUILEC = $(AM_V_GUILEC_$(V))
+AM_V_GUILEC_ = $(AM_V_GUILEC_$(AM_DEFAULT_VERBOSITY))
+AM_V_GUILEC_0 = @echo " GUILEC" $@;
# XXX: Use the C locale for when Guile lacks
# <http://git.sv.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=e2c6bf3866d1186c60bacfbd4fe5037087ee5e3f>.
.scm.go:
- $(MKDIR_P) `dirname "$@"`
+ $(AM_V_GUILEC)$(MKDIR_P) `dirname "$@"` ; \
LC_ALL=C \
$(top_builddir)/pre-inst-env \
$(GUILD) compile -L "$(top_builddir)" -L "$(top_srcdir)" \