summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c22a77f1e..a1a87c09fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,9 @@ MODULES = \
guix/build/syscalls.scm \
guix/build/emacs-utils.scm \
guix/packages.scm \
- guix/snix.scm \
+ guix/import/utils.scm \
+ guix/import/snix.scm \
+ guix/import/pypi.scm \
guix/scripts/download.scm \
guix/scripts/build.scm \
guix/scripts/archive.scm \
@@ -89,6 +91,8 @@ MODULES = \
guix/scripts/refresh.scm \
guix/scripts/system.scm \
guix/scripts/lint.scm \
+ guix/scripts/import/nix.scm \
+ guix/scripts/import/pypi.scm \
guix.scm \
$(GNU_SYSTEM_MODULES)
@@ -162,6 +166,12 @@ SCM_TESTS = \
tests/syscalls.scm \
tests/lint.scm
+if HAVE_GUILE_JSON
+
+SCM_TESTS += tests/pypi.scm
+
+endif
+
SH_TESTS = \
tests/guix-build.sh \
tests/guix-download.sh \