summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 29 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index f99215145c..e2c940ca8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,13 +2,14 @@
# Copyright © 2012, 2013, 2014, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
# Copyright © 2013 Andreas Enge <andreas@enge.fr>
# Copyright © 2015, 2017 Alex Kost <alezost@gmail.com>
-# Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-# Copyright © 2016, 2017 Mark H Weaver <mhw@netris.org>
+# Copyright © 2016, 2018 Mathieu Lirzin <mthl@gnu.org>
+# Copyright © 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
# Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
# Copyright © 2017 Leo Famulari <leo@famulari.name>
# Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
# Copyright © 2017 Jan Nieuwenhuizen <janneke@gnu.org>
# Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+# Copyright © 2018 ng0 <ng0@n0.is>
#
# This file is part of GNU Guix.
#
@@ -25,8 +26,20 @@
# You should have received a copy of the GNU General Public License
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-bin_SCRIPTS = \
- scripts/guix
+bin_SCRIPTS = scripts/guix
+
+# Handle substitution of fully-expanded Autoconf variables.
+do_subst = $(SED) \
+ -e 's,[@]GUILE[@],$(GUILE),g' \
+ -e 's,[@]guilemoduledir[@],$(guilemoduledir),g' \
+ -e 's,[@]guileobjectdir[@],$(guileobjectdir),g' \
+ -e 's,[@]localedir[@],$(localedir),g'
+
+scripts/guix: scripts/guix.in Makefile
+ $(AM_V_at)rm -f $@ $@-t
+ $(AM_V_at)$(MKDIR_P) "$(@D)"
+ $(AM_V_GEN)$(do_subst) < "$(srcdir)/$@.in" > "$@-t"
+ $(AM_V_at)chmod a+x,a-w "$@-t" && mv -f "$@-t" "$@"
nodist_noinst_SCRIPTS = \
pre-inst-env \
@@ -241,6 +254,9 @@ dist_noinst_DATA = guix/tests.scm guix/tests/http.scm
# Auxiliary files for packages.
AUX_FILES = \
gnu/packages/aux-files/emacs/guix-emacs.el \
+ gnu/packages/aux-files/linux-libre/4.15-arm.conf \
+ gnu/packages/aux-files/linux-libre/4.15-i686.conf \
+ gnu/packages/aux-files/linux-libre/4.15-x86_64.conf \
gnu/packages/aux-files/linux-libre/4.14-arm.conf \
gnu/packages/aux-files/linux-libre/4.14-i686.conf \
gnu/packages/aux-files/linux-libre/4.14-x86_64.conf \
@@ -427,12 +443,20 @@ dist_bashcompletion_DATA = etc/completion/bash/guix
# Zsh completion file.
dist_zshcompletion_DATA = etc/completion/zsh/_guix
+# Fish completion file.
+dist_fishcompletion_DATA = etc/completion/fish/guix.fish
+
+# SELinux policy
+dist_selinux_policy_DATA = etc/guix-daemon.cil
+
EXTRA_DIST = \
HACKING \
ROADMAP \
TODO \
CODE-OF-CONDUCT \
.dir-locals.el \
+ bin/guix.in \
+ etc/guix-install.sh \
build-aux/build-self.scm \
build-aux/compile-all.scm \
build-aux/hydra/evaluate.scm \
@@ -468,6 +492,7 @@ endif !BUILD_DAEMON_OFFLOAD
CLEANFILES = \
+ $(bin_SCRIPTS) \
$(GOBJECTS) \
$(SCM_TESTS:tests/%.scm=%.log)