summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cf9314014..ada4cbea0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -279,6 +279,7 @@ EXTRA_DIST = \
build-aux/check-final-inputs-self-contained.scm \
build-aux/download.scm \
build-aux/make-binary-tarball.scm \
+ build-aux/generate-authors.scm \
srfi/srfi-37.scm.in \
srfi/srfi-64.scm \
srfi/srfi-64.upstream.scm \
@@ -389,9 +390,12 @@ gen-ChangeLog:
fi
gen-AUTHORS:
- $(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/generate-authors.scm" \
- "$(top_srcdir)" "$(distdir)/AUTHORS"
+ if test -d .git; then \
+ rm -f "$(distdir)/AUTHORS"; \
+ $(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/generate-authors.scm" \
+ "$(top_srcdir)" "$(distdir)/AUTHORS"; \
+ fi
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names: