summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 5cf9314014..870c6f914b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -389,9 +389,12 @@ gen-ChangeLog:
fi
gen-AUTHORS:
- $(top_builddir)/pre-inst-env "$(GUILE)" \
- "$(top_srcdir)/build-aux/generate-authors.scm" \
- "$(top_srcdir)" "$(distdir)/AUTHORS"
+ if test -d .git; then \
+ rm -f "$(distdir)/AUTHORS"; \
+ $(top_builddir)/pre-inst-env "$(GUILE)" \
+ "$(top_srcdir)/build-aux/generate-authors.scm" \
+ "$(top_srcdir)" "$(distdir)/AUTHORS"; \
+ fi
# Make sure we're not shipping a file that embeds a local /gnu/store file name.
assert-no-store-file-names: