summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 18 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 53efa4a684..398846f64b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,20 @@ AC_ARG_WITH([zsh-completion-dir],
[zshcompletiondir='${datadir}/zsh/site-functions'])
AC_SUBST([zshcompletiondir])
+AC_ARG_WITH([fish-completion-dir],
+ AC_HELP_STRING([--with-fish-completion-dir=DIR],
+ [name of the Fish completion directory]),
+ [fishcompletiondir="$withval"],
+ [fishcompletiondir='${datadir}/fish/vendor_completions.d'])
+AC_SUBST([fishcompletiondir])
+
+AC_ARG_WITH([selinux-policy-dir],
+ AC_HELP_STRING([--with-selinux-policy-dir=DIR],
+ [name of the SELinux policy directory]),
+ [selinux_policydir="$withval"],
+ [selinux_policydir='${datadir}/selinux/'])
+AC_SUBST([selinux_policydir])
+
dnl Better be verbose.
AC_MSG_CHECKING([for the store directory])
AC_MSG_RESULT([$storedir])
@@ -117,6 +131,8 @@ dnl Make sure we don't suffer from the bug in 'equal?' wrt. syntax objects
dnl found in 2.2.1. See <https://bugs.gnu.org/29903>.
GUIX_ASSERT_SYNTAX_OBJECT_EQUAL
+AC_PROG_SED
+
dnl Decompressors, for use by the substituter and other modules.
AC_PATH_PROG([GZIP], [gzip])
AC_PATH_PROG([BZIP2], [bzip2])
@@ -263,9 +279,9 @@ esac
AC_CONFIG_FILES([Makefile
po/guix/Makefile.in
po/packages/Makefile.in
- guix/config.scm])
+ etc/guix-daemon.cil
+ guix/config.scm])
-AC_CONFIG_FILES([scripts/guix], [chmod +x scripts/guix])
AC_CONFIG_FILES([test-env:build-aux/test-env.in], [chmod +x test-env])
AC_CONFIG_FILES([pre-inst-env:build-aux/pre-inst-env.in],
[chmod +x pre-inst-env])